No announcement yet.

Win98 DHCP Clients not Registering in DNS Host Table

  • Filter
  • Time
  • Show
Clear All
new posts

  • Win98 DHCP Clients not Registering in DNS Host Table

    (Note...originally posted this in the Client OS forum...but more and more appears to be server OS related)

    We have a very aggrivating problem. We are in the process of cleaning up a very messy inherited network. Converting everyone from static IP's, across multiple nets to DHCP on a single net. Our DHCP is on a Win2KServer which is also our DNS box. We have a mix of Win98 & Win2K clients (~150 or so). We are also making them domain users as we go. Both the Win98 and Win2K machines are converting to the domain, taking the assigned IP from DHCP normally and are showing up in the address lease list, although the Win2K boxes are adding a .com to the domain while the Win98 are not...not sure if this is important but trying to give all info.

    The problem is that while the Win2K boxes are registering and visible in the DNS host table after being moved to DHCP, the Win98 boxes are not. This is a critical problem for us as we have a major interface that is going to rely on DNS entries. We can ping the IP's of other servers but cannot ping them by DNS name. Can also ping the DNS box but cannot see it by name. An IPCONFIG /all shows all the correct information, including DNS IP.

    We have scoured the net and tried everything we have found to no avail. This includes:

    --> Installing the Win2K DS Client on the Win98 box
    --> On the DHCP DNS tab for both server and scope, we have enabled DNS for clients who don't support dynamic updates and always update DNS
    --> Followed the directions on Petri's site for Active Directory Client for Win98/NT
    --> Applied the MS hotfix for the this same issue (see Knowledge Base article Q242000)

    Looking for any wisdom on this challenge. Worried that part of the problem may be our current net config...we inherited a major mess from the folks before us. We have 3 different nets (130.0.0.n, 192.168.1.n, 192.168.100.n), taking everying to 192.168.69.n (we had to have a little fun with the numbering). We have a Watchguard Firebox on the wall with multiple gateways and routes defined but not clearly understood. We are doing everything we can to figure it out.

    So, first question is: is the problem an OS issue or a net issue? I did see a portion in the Win2K Resource Kit regarding option 81 on the DHCP options and FQDN, however, out DHCP options only go to 76.

    Any help would be greatly appreciated as this is kicking out butts...

  • #2
    I have done this before... but with W2003 DHCP. This has an option to run the DDNS updates with a service account. Once I configured that, the updates proceded normally for W98 clients.

    With W2000, you might to run the DHCP service itself under a service account that can update the relevant zone.

    interesting problem, let us know how you get on.


    • #3
      Couple of questions...what are calling a service account? Are you referring to the DHCP service and how it logs on (i.e. the Log On tab of the DHCP Service Properties in the Services area?) Currently, it is set to logon as Local System Account. Are you saying to actually give it's own logon with admin privledges?


      • #4
        > Are you saying to actually give it's own logon with admin privledges?

        That's right. Another thing to try (I didn't at the time) is to add the computer account of the DHCP server to the DnsUpdateProxy group, as mentioned here:


        • #5
          okay...tried to give it it's own logon and ran into an interesting problem. Basically, I went into the active directory and added a user called "dhcp_services", made it a member of the administrative and DNSUpdateProxy groups. Went to Services, DHCP server and properties. Under the LogOn tab, changed from "local machine" to "dhcp_services" with the applicable password. Applied, stopped and restarted the service. Appeared to start without issue.

          Then, when I went back to the DHCP server, I was no longer allowed access to the DHCP server...received a message "You do not have access to this DHCP server. To view information on a DHCP server, you must be logged in as an Administrator, DHCP Administrator, or DHCP User."

          The funny thing is that I am logged onto the system as the administrator. I have tried this with a number of different configs and options, all with the same result. I even went in and manually added "administrator" to the DHCP Administrator security group with the same result.

          So my questions are: 1.) Do I need to re-grow the DHCP server after I make the log on change? 2.) Have I done something incorrect with the AD logon?

          I will be more than happy to attach screen caps if you'd like to see how it is all setup.

          And...I truly appreciate your help with this...I have not had formal training in network admin and this is a wild crash course on DHCP & DNS.


          • #6
            Sorry, forgot about that. Seems to be a bug, I never found a way to access the DHCP config directly at this point. To edit DHCP service you need to re-start it using LOCALSYSTEM.

            But, does it work now? Do the W98 clients register?


            • #7
              Is this fun or what?!

              I went ahead and told the DHCP Server to login with an account...which makes me unable to get to the server as discussed prior. When I turned the Win98 box on, got error 59 - a network error has occured...but continued with login. Box pulled a DHCP addy but still does not show up in DNS.

              I have attached a screen capture that shows a bunch of my info. On the DHCP window, you can see - it_test.nrmc highlighted. This is our Win98 test box. In the DNS window, you can see Info-Tech highlighted...below that is where the it_test should be showing up but isn't. I have also opened the windows for both the server and scope DNS properties.

              The second screen cap is of the active directory entry for the login I gave the dhcp service as well as the dhcp scope options.

              I hope this information helps figure this out.

              As a side questions...what is causinig the bad addresses in the DHCP window?
              Attached Files


              • #8
                What kind of dns zone are we taking about?
                Dynamic updates are checked on that zones?!
                DHCP are allowed to register that type of records by the client?
                MCSE w2k
                MCSA w2k - MCSA w2k MESSAGING
                MCDBA SQL2k


                • #9

                  This is an AD integrated, forward lookup zone and yes, the "allow dynamic updates" box under the zone's DNS properties is set to "yes".

                  You have me at a bit of a loss on the last question...DHCP being allowed to register these types of records by client? Can you be more specific?

                  Also, we just discovered a small item. Before, from the Win98 box, we could not ping by dns name but could by ip....for example we couldn't ping "Silo" but could ping it's ip of Turns out, from MS Knowledgebase item Q227120, that this is from a NetBIOS bug. When we put a period on the name, i.e. "Silo.", the Win98 box sees the DNS entry. This tells us at the minimum that our Win98 box can see and hit the DNS server.


                  • #10
                    I'm a bit out of idea's here. One thing to try is to exclude that it is a security problem. It's a bit radical, and only suited for a test environment, but you could set the dynamic updates to non-secure. If that works, it is some convoluted security issue. If it fails, it should be something in DHCP.

                    Now that I'm thinking about it, just to make doubly sure:
                    - DHCP is a proper domain member?
                    - The DHCP server can find the DNS?


                    • #11
                      Need more help?
                      MCSE w2k
                      MCSA w2k - MCSA w2k MESSAGING
                      MCDBA SQL2k


                      • #12
                        Need more help?
                        MCSE w2k
                        MCSA w2k - MCSA w2k MESSAGING
                        MCDBA SQL2k


                        • #13
                          Need more help?
                          MCSE w2k
                          MCSA w2k - MCSA w2k MESSAGING
                          MCDBA SQL2k


                          • #14
                            Again...thanks so much for y'all taking your time to help with this.

                            Wkasdo, we thought about that too...trick is, everything work great with Win2K clients. We are only having this problem with Win98 clients. The Win2K clients are showing up correctly in the DNS table with their applicable leased DHCP IP. Wouldn't this exclude any security issues as well as indicate that our DHCP is a proper domain member that can see the DNS?

                            Windux, according to the link you sent, "Microsoft Windows 98-based computers, however, place their NetBIOS information into the Host field, so the DHCP server updates the DNS server with the Windows 98 NetBIOS name information, and not the DNS host name information." So, I took another look at the DNS table and this time, looked for the IP that was assigned our test box... did not find it anywhere.

                            Where is the NetBIOS info kept on a 98 box? If the issue was just where the name is coming from, wouldn't the IP still show up in the DNS table?


                            • #15
                              Sorry, missed your update.

                              > . Wouldn't this exclude any security issues as well as indicate that our DHCP is a proper domain member that can see the DNS?

                              No, because the DHCP is doing the update now with its own account. W2000 and better do it themselves. So I thought it would be worth it to exclude a security issue. Note that if the DHCP were not a domain member then everything would be explained ...

                              > Where is the NetBIOS info kept on a 98 box?

                              The article basically says that w98 has no DNS name of its own, and therefore uses the netbios name. Somewhat obvious. But it reminds me of something else. Is the workgroup name identical to the domain name?
                              Thought about that earlier, but discarded it because you had a working workgroup. Basically, the workgroup name of W98 should match the netbios name of the domain.