No announcement yet.

File Replication Service issue

  • Filter
  • Time
  • Show
Clear All
new posts

  • File Replication Service issue

    Please forgive my ignorance with w2k3 server as I'm a linux guy for servers.

    OS: Windows Server 2003 Standard Edition SP2
    New installation
    Fully updated with all patches

    Essentially I am trying to install and setup Exchange 2007. To install Exchange 2k7 I understand that the server requires AD to be installed.

    So I attempt to install AD using your tutorials on the site here. Here are the tutorials I have completed


    On the last tutorial I run into an issue at the point where it says Promote This Server to Domain Controller (Optional - Recommended)

    It stops with the error

    The file replication service cannot be started.

    I do some reading and find a tool called FRSDiag and I run it. Here's an error that shows up at least a dozen times.

    Checking for errors/warnings in FRS Event Log ....
    The File Replication Service detected an invalid parameter value in
    the registry. .

    The expected registry key name is "System\CurrentControlSet\Services
    The expected value name is "Working Directory".
    The expected registry data type is REG_SZ.
    The allowed range for this parameter is
    The data units for this parameter value are .
    The File Replication Service is using a default value of "".

    To change this parameter, run regedit.

    Click on Start, Run and type regedit.

    Click down the key path: "System\CurrentControlSet\Services\NtFrs
    Double click on the value name -
    and update the value.
    If the value name is not present you may add it with the New function
    under the Edit Menu item. Type the value name exactly as shown above
    using the above registry data type. Make sure you observe the data
    units and allowed range when entering the value.

    NOTE - I cleaned that up to make it more readable, frsdiag spits it out all on one line

    So I go check and HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\NtFrs\Parameters is empty

    I go do some more checking and see that /Parameters needs a Reg_SZ key called "Working Directory" and a path. So I add it and restart the server. And now I'm right back to where I was.

    FRS will not start and I still get the error that the registry is incorrect.

    Any help please? Did I miss something along the way?

  • #2
    Re: File Replication Service issue

    Issue resolved. courtesy of Isaac Oben

    The "System\CurrentControlSet\Services\NtFrs\Parameter s" should have a value
    name Working Directory of type REG_EXPAND_SZ and value should be:

    Changing the regkey fixed the issue and allowed me to install AD


    • #3
      Re: File Replication Service issue

      Hi Simon,

      Thanks for posting back your findings, much appreciated, bit of an odd issue there too.
      Do you have a link to the page that helped you at all, to aid anyone else that finds this post?

      Please read this before you post:

      Quis custodiet ipsos custodes?