Please Read: Significant Update Planned, Migrating Forum Software This Month

See more
See less

IIS FTP permissions issues

  • Filter
  • Time
  • Show
Clear All
new posts

  • IIS FTP permissions issues

    First I will prefece that I have tried the below procedure on two different systems, one running R2, one not, both running SP2.

    I am trying to set up an FTP server using IIS 6 so that I can have grant different users read/write accesses to different areas. I am NOT looking for a home drive type system, but rather a common share where I can control read/write. I also do not want any anonymous access. Here is what I attempted:

    Created a folder on my drive to act as my FTP root. Removed inheritance, and set allow permissions for my user account, and a web downloaders group. I removed all other permissions. I then logged into my ftp server using IE, just using ftp://localhost. I was prompted to authenticate. However, when I use a test user that is not part of the downloaders group, they still have full access. Even when I set an exlicit deny on the folder I still get the same result.

    I do not want any authenticated users to be able to access the ftp site even the root. I want the users to have to be a member of the web downloaders group. Why is FTP ignoring permissions? I have removed all other entries(IE administrator system etc). I have tried this with AD accounts and local accounts and got the same result. I have read numerous tutorials on how to do this and based on the instructions what I did should work.

  • #2
    Re: IIS FTP permissions issues

    There are two issues at work here: 1.) the FTP protocol permissions and 2.) the NTFS folder permissions. Can you be specific in telling us: 1.) What FTP protocol permissions you have set on the properties of the FTP server (read, write, anonymous access) and 2.) What NTFS permissions are on your ftp root folder.


    • #3
      Re: IIS FTP permissions issues

      I set read/write, and I unchecked the box for allow anonymous on the security tab. on the FTP root I set my account to full access and web downloaders read/access