Announcement

Collapse
No announcement yet.

Unable to set permissions!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to set permissions!

    I am running server 2003 and on our network is a network drive on which everyone works. I need to change permissions for certain folders on said drive but every time I try I get an "access denied" error! I can edit files on the drive as I please but not change permissions, how can this be when I am administrator? Help ASAP recquired! Thanks in advance.

  • #2
    Re: Unable to set permissions!

    Do you have Full Control permissions of the folders in question?
    Gareth Howells

    BSc (Hons), MBCS, MCP, MCDST, ICCE

    Any advice is given in good faith and without warranty.

    Please give reputation points if somebody has helped you.

    "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

    "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

    Comment


    • #3
      Re: Unable to set permissions!

      Judging by this, you don't have full control permisisons on the security. Look at the NTFS permissions to see who has, otherwsie, if you are an administrator, take ownership of the folder, keep existing permissions and then add yourself in (adminstrators group) to the folder and then set Full Control.

      Comment


      • #4
        Re: Unable to set permissions!

        Or permissions based on the Share itself.
        cheers
        Andy

        Please read this before you post:


        Quis custodiet ipsos custodes?

        Comment


        • #5
          Re: Unable to set permissions!

          I do have full control of the external drive as far as I am aware. Where would I check the ownership settings? I saw on another site that it appears one has to utilise the web interface for a given network drive in order to alter the permissions and/or users. I have done so but all appears to be in order. Does anyone know the truth of that statement? Is there no way to change the permissions for individual files and folders in the drive? Thanks again.

          Comment


          • #6
            Re: Unable to set permissions!

            First of all make sure that your account is listed under Share permissions and that it has Full Controll. Next check Security permissions and make sure your account is listed and that it has Full Control. Sometimes, adding an account after files and folders have already been created in a share will not give you the permissions you expect.

            On the Security Tab of the shared Folder properties, hit the advanced tab and choose the option to replace permissions with entries as shown here. Note that this will change the permissions on ALL sub folders and files to the ones shown.

            If you have specific permissions set on sub-folders you will need to change those individually without doing the step above otherwise specific permissions (e.g. restrictions) will be removed.
            A recent poll suggests that 6 out of 7 dwarfs are not happy

            Comment


            • #7
              Re: Unable to set permissions!

              Woah, woah, woah, Blood! I'm new to this. How am I going to check these permissions (by which I mean WHERE on server?) And also, how do I take ownership? Thanks!

              Comment


              • #8
                Re: Unable to set permissions!

                Right click on the folder in question. Click Properties. You will see tabs for Sharing and Security.

                Ownership is accessible by clicking Advanced on the Security tab.
                Gareth Howells

                BSc (Hons), MBCS, MCP, MCDST, ICCE

                Any advice is given in good faith and without warranty.

                Please give reputation points if somebody has helped you.

                "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

                "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

                Comment


                • #9
                  Re: Unable to set permissions!

                  Oh thanks mate, I set the owner to administrator, but I am still unable to change permissions on any subfolders. Looks like this is going to be quite involved so let me give you some background. We have the external which I now accessed a subfolder (the main one everyone works in) of to change ownership. Subfolders of that folder I am unable to change permissions of. How could I change the owner of the drive itself? If I access the properties of the drive in the network (Entire Windows Network->Domain->EMC Device) there is no security tab in there. Thanks for the help so far.

                  Comment


                  • #10
                    Re: Unable to set permissions!

                    Originally posted by threefifty View Post
                    If I access the properties of the drive in the network (Entire Windows Network->Domain->EMC Device) there is no security tab in there.
                    That isn't the properties dialog of the drive. That is the properties dialog of the server the drive is in. Which from your posts, sounds like a NAS? Which one?
                    Gareth Howells

                    BSc (Hons), MBCS, MCP, MCDST, ICCE

                    Any advice is given in good faith and without warranty.

                    Please give reputation points if somebody has helped you.

                    "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

                    "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

                    Comment


                    • #11
                      Re: Unable to set permissions!

                      When you set the owner, there is a box at the bottom that enables you to 'replace owner on subcontainers and objects'.

                      You can not set the NTFS permissions via your method. The way you are accessing it is via a share.

                      If you logon to the computer that has the external HDD and then go to Properties and then security etc and do the same regarding ownership but then ensure 'replace owner on subcontainers and objects', you can then add your account as an NTFS permission as full control.

                      You are taking ownership but you will be unable to access until you have added yourself in. Again, then take advantage of inheritance. When you go on advanced, the first tab is Permissions, check the 'Replace permission entries on all Child Objects....' and then apply it. Good luck.

                      Comment


                      • #12
                        Re: Unable to set permissions!

                        Uh, I'm not sure... I believe it is a NAS, as it's an external drive connected by network and incapable of any computing activities other than storage. How would I find the information you seek? By the way, I just set the owner for the drive (which I mapped), and all sub-objects, to administrator, but while it was in the process it gave me many an error of access denied for individual files. I clicked cancel, and received another error that the settings are in a state of incompletion (or something like that). The owner is now shown as Administrator but when I change permissions for folders the settings immediately revert on apply, although I get no error. Should I be going 'uh-oh'? Apparently the OS of the drive (if there is such a thing) is Windows NT Server 4.9

                        Comment


                        • #13
                          Re: Unable to set permissions!

                          Originally posted by threefifty View Post
                          How would I find the information you seek?
                          Would the make and model (certainly the make) not be written on it? And if you know the manufacturer, you can find out the model...
                          Gareth Howells

                          BSc (Hons), MBCS, MCP, MCDST, ICCE

                          Any advice is given in good faith and without warranty.

                          Please give reputation points if somebody has helped you.

                          "For by now I could have stretched out my hand and struck you and your people with a plague that would have wiped you off the Earth." (Exodus 9:15) - I could kill you with my thumb.

                          "Everything that lives and moves will be food for you." (Genesis 9:3) - For every animal you don't eat, I'm going to eat three.

                          Comment


                          • #14
                            Re: Unable to set permissions!

                            Virtual, I cannot access the machine the drive is on because the drive is a machine itself! It's a network drive, and shows up on Active Directory as a computer...

                            Comment


                            • #15
                              Re: Unable to set permissions!

                              External or internal HDD, it is still the same principal. You need to go to the computer.

                              Are you an administrator for that machine?

                              I was referring to the physical drive not the shared drive.

                              Comment

                              Working...
                              X