No announcement yet.

cannot rejoin my workgroup computer to my domain

  • Filter
  • Time
  • Show
Clear All
new posts

  • cannot rejoin my workgroup computer to my domain

    hi, i have major problem.

    i removed a network computer of mine from the domain and created a workgroup for it. now i want to rejoin the domain but it says the specified domain does not exist or could not be contacted. it is there, cuz my other network clients do not have a problem contacting the DC. i've checked my dns settings and they are correct. on this problem workgroup computer i can't even connect to the internet.
    i've tried everything i know, but cannot rejoin this computer to the domain.
    please help me someone!

  • #2
    solution: cannot join domain

    Thats not a big problem,

    You only need to uninstall NETBEUI protocol from the network and dialup connection and then reinstall the protocol and then join the domain................thats simple...........


    • #3
      You know, it does sound a bit like a dns problem. If you do 'nslookup', it should give you the list of DC's in your domain. Does it?

      Did you perhaps set the IP settings manually and put in the wrong subnet or gateway?


      • #4
        i found the answer to this problem

        hey guys,

        thanks for replying so fast. you know i spent the better part of 3 days on this before figuring it out.
        forgot to add some additional facts about this problem. All my dns settings were correct. i'm quite meticulous with my dns settings. The computer that i was working on was, i repeat...WAS... a member server and i was having problems connecting to my new domain controller which i started on from scratch since the old disk had a corrupt active directory(which i tried to fix, but we'll leave that for another day). So i removed the compter from the domain and added it to a workgroup. I played around with it abit, and still had no network or internet connection. To complicate matters i couldn't join it back to the previous domain it had belonged to.

        So the member server had services running on it from the previous DC.All the bells and whistles.
        Usually i would go along with you guys and say it's a DNS problem, but it wasn't. I also ran the ipconfig /flushdns command along with /registerdns command to register all the hosts on my network. i also made sure my tcp netbios helper service was running. This didn't work though. i still had no internet connection or network connection on this problem machine.
        Can u guess what the problem was. before i tell u; you know what i wish? I wish there was an easy way to find a solution to a problem on the internet. Most of the web sites want money, which is bs. One day i hope to make a non-profit web site like Daniel's where every mcse problem is listed along with the solutions. No where did i find the answer to this problem. Lost a lot of sleep over it.

        Anyhow, turns out on a hunch; i went to my problem computers running services. It turns out that some security settings set by my previous DC were still running on the workgroup computer. To be precise, it was my ipsec policy agent service. i disabled it and bingo bango i had my internet connection back along with my network connection. Now all i had to do was rejoin my workgroup computer back to the domain. Worked nice as pie. Before i did this it wouldn't let me join the domain and stated an error that the domain either did not exist or could not be contacted. While it couldn't be contacted because of the ipsec security settings set by the previous DC.

        So to all out there, don't forget to check your security settings because it could block your computer from communicating with other machines on your network as well as the internet. Like i said it isn't always a DNS or protocol issue.

        Thanks to all who replied to my post.


        THANKS, LEON


        • #5
          Thank you for sharing this information.

          Daniel Petri
          Microsoft Most Valuable Professional - Active Directory Directory Services
          MCSA/E, MCTS, MCITP, MCT