Announcement

Collapse
No announcement yet.

Computer Browser Service Stops [Server 2003 SP1]

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Computer Browser Service Stops [Server 2003 SP1]

    Hi there,

    I have a problem with the Computer Browser Service stopping. Sometimes it will run for a couple days, other times it will crash a few times an hour.

    Here are some details:

    - OS: Server 2003 SP1
    - Computer Browser Service is set to start automatically
    - Sometimes this is the only service that fails. Other times, multiple services fail.
    - The Event Viewer is not logging all failures.

    For example, yesterday I was transferring a file to the server hosting the Computer Browser Service. My transfer was interrupted, and I was no longer able to browse the share on the server. I logged into the server, and found that the service was not running (although it is set to automatic). There were no events in the Event Viewer saying the service failed, or any other events indicating any failures whatsoever. When I manually restarted the service the Even Viewer logged that the service was being started. I also set the recovery options to restart the service upon failure, although this is not a desirable solution.

    So I was able to do my transfer again, and I went home. When I came back this morning, I found that the service was failed / restarted again. But this time, there was an entry in the Event Viewer:

    ====================================
    Event Type: Error
    Event Source: Service Control Manager
    Event Category: None
    Event ID: 7031
    Date: 1/19/2009
    Time: 10:14:21 PM
    User: N/A
    Computer: UOTTW056
    Description:
    The Computer Browser service terminated unexpectedly. It has done
    this 1 time(s). The following corrective action will be taken in
    60000 milliseconds: Restart the service.
    For more information,
    see Help and Support Center at
    http://go.microsoft.com/fwlink/events.asp.
    ====================================

    Multiple services also failed during this event:
    - Windows Management Instrumentation
    - System Event Notification
    - Workstation Service
    - Server Service
    - COM+ Event System service
    - Background Intelligent Transfer Service
    - Application Experience Lookup Service


    Most of the time, there are not events logged whatsoever when this service fails. Before I set the recovery options, I would just log into the server, confirm nothing has been logged, and start the service manually.

    This server is rebooted every couple days. This morning, I tried a couple things:

    - Ran Virus Scan, which completed without warnings.
    - Logged into server and checked the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Browser\Parameters
    Verified server is not set as master, so that there would be no conflicts with other servers. Also verified that the MaintainServerList value is set to 'yes'
    - Verified that the Windows Firewall was not running.

    {...}

    What worries me about this is that the behavior is not consistant in regards to logging. I come from the UNIX world, so I'm afraid I might be missing something simple with this Windows stuff. If anyone couple provide any suggestions, documentation, or links to other articles, it would be greatly appreciated.

    Thanks in advance.

    EDIT: svchost.exe crashed multiple times this morning. I'm not sure if this is related, as I don't believe svchost.exe crashes very often (if ever).
    Last edited by paidbythehour; 20th January 2009, 17:14. Reason: Additional details

  • #2
    Re: Computer Browser Service Stops [Server 2003 SP1]

    I would make sure your box is fully up to date with the windows patches and then scan with another AV product.
    Which AV do you have installed?

    Update your NIC drivers (and others if there are updates available).
    What does this server host?
    cheers
    Andy

    Please read this before you post:


    Quis custodiet ipsos custodes?

    Comment


    • #3
      Re: Computer Browser Service Stops [Server 2003 SP1]

      Thx for the suggestions.

      Originally posted by AndyJG247 View Post
      I would make sure your box is fully up to date with the windows patches and then scan with another AV product.
      Which AV do you have installed?
      There has been minimal patching since SP1, but this machine is on an isolated network (no public net access). I talked to my 'peer' about updating, but he seemed wary. I agree that the machine should be fully patched, but it will take a little arm-twisting before I can make it happen.

      The antivirus software is McAfee 8.0.0 and receives daily updates via an internal server. I might have a newer version kicking around somewhere to install.

      Originally posted by AndyJG247 View Post
      Update your NIC drivers (and others if there are updates available).
      What does this server host?
      I have the updated NIC drivers.

      This server just shares out a couple drives. We use it to keep our ISO's or any windows software that we might need around our lab. There is a bunch of stuff running right now:

      - vmware
      - IIS
      - SQL Server

      We don't have many windows boxes, so we use this one for testing / support.

      Again, any further suggestions / documentation is greatly appreciated.

      Thx.

      Comment


      • #4
        Re: Computer Browser Service Stops [Server 2003 SP1]

        I may have solved my own problem here ...

        I got a couple more svchost.exe crashes this morning, and I googled the error code (0x7c90568c). I found a couple other users who had the same problem, and it seems to be the conflicker worm (See MS patch MS08-067).

        I attempted to down load the patch (Running IE in secure mode) and after starting the download my browser prompted to add an exception for view.atdmt.com (spyware).

        So it looks like my PC has been sleeping around ...

        Found another unpatched PC in our lab, so I'm still tracking down where things started. Consider this thread closed unless I post again.

        Thanks again for the hand!

        Comment


        • #5
          Re: Computer Browser Service Stops [Server 2003 SP1]

          Good luck then. Even machines that are in a clean environment are at risk. I would look at getting offline WSUS or something like that maybe?
          cheers
          Andy

          Please read this before you post:


          Quis custodiet ipsos custodes?

          Comment

          Working...
          X