No announcement yet.

cannot install Certificate Services

  • Filter
  • Time
  • Show
Clear All
new posts

  • cannot install Certificate Services

    Help! I wanted to clean up the CA on our server - so I followed
    and now trying to re-install certificate services, I get an error 0x4b8 (could not copy file). If I click OK it gives me an error "Could not find module C:\Windows\System32\certenc.dll" 0x8007007e Win32/http:126

    I've tried downloading a certenc.dll and putting it in the System32 folder, then regsvr32 to register it - but it says "Cannot find module C:\Windows\System32\certenc.dll". I've tried installing Certificate Services directly from my CD, with the same result. Help! I can't find anything on the internet to resolve this issue.

  • #2
    Re: cannot install Certificate Services

    Update - finally got rid of the first problem. I tried putting the downloaded certenc.dll on the C: drive and registering it there - I then got an error that MSOSS.DLL was missing. So I downloaded that, put them both in the System32 folder, and got a new error - same messages, but related to certdb.dll.

    I downloaded that one, then tried to reinstall Certificate Services. This time, I got the "0x4b8" error, and a "missing module" error, but no filename. However, it did install the Web Enrollment portion - but not the CA. In order to install the CA, I first had to uninstall Certificate Services. When I did that, I found it removed certenc.dll. So I copied and pasted it again into the system32 folder and tried to reinstall - this time I got the same errors, with a filename of scrdenrl.dll.

    After doing the same steps over again, ran into a similar problem - two error messages, no file name. This time looking in the certocm.log file I found it was looking for xenroll.dll in a different folder.

    After exhaustive back and forth finding what files it needed and puttting them in the right folder (including the certsrv.exe into the System32 folder) I finally got it to install.

    Now to try get OWA and OMA running with self-signed certs.... *sigh*