Announcement

Collapse
No announcement yet.

Setting up VPN for Terminal Services

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setting up VPN for Terminal Services

    Server: Windows 2003 R2

    Problem: Confused about what I'm doing wrong (just started learning/reading on VPN).
    Goal: Setting up VPN so I can use it for terminal services RDP connection

    Current Setup: Server with VPN role enabled is behind a router (there is one other devices behind the router but it is not networked with the server ). I have a client computer on a different internet line (different IP from the router) with VPN connection added, which is being used for testing.
    In the client I have entered the IP of the server's router as it appears to the internet, but I cannot connect. What am I doing wrong?

    1) Should I forward some port or something to the server's LAN IP?
    2) My router has a setting called NAT Filtering which is currently set to secure...should I turn that off maybe?-I mention NAT because I came accross it in my readings about VPN.
    3) Simply adding VPN role to server and adding VPN connection to client doesn't do it. Didn't find anything on web explaining how to solve issue with router in front of server....please help.

    Thank you

  • #2
    Re: Setting up VPN for Terminal Services

    Your router isn't accepting the VPN tunnel, while the server is.
    You have to set-up forwarding in your router that it forwards the tunnel to your server. Some routers call it "virtual servers". Check the manual of your router.
    [Powershell]
    Start-DayDream
    Set-Location Malibu Beach
    Get-Drink
    Lay-Back
    Start-Sleep
    ....
    Wake-Up!
    Resume-Service
    Write-Warning
    [/Powershell]

    BLOG: Therealshrimp.blogspot.com

    Comment


    • #3
      Re: Setting up VPN for Terminal Services

      My router doesn't support VPN
      thanks for assistance
      Last edited by HotDay2222; 25th September 2008, 10:37.

      Comment


      • #4
        Re: Setting up VPN for Terminal Services

        Originally posted by HotDay2222 View Post
        My router doesn't support VPN
        thanks for assistance

        Yes, but under NAT you can still configure port forwarding:

        RADIUS Authentication 1812 To your VPN server IP
        RADIUS Accounting 1813 To your VPN server IP

        So, you forward RADIUS ports 1812 and 1813 to your VPN servier IP address. Does not matter if your router supports VPN.

        Have you also enabled RRAS?
        A recent poll suggests that 6 out of 7 dwarfs are not happy

        Comment


        • #5
          Re: Setting up VPN for Terminal Services

          RSAA has to be enabled in order for server to be VPN server.
          It is RSAA that is managing the connection.

          I also have Internet Services Applications enabled.

          Really new to all of this NAT, and RSAA stuff. So learning.

          Comment


          • #6
            Re: Setting up VPN for Terminal Services

            Don't forget to also forward ports 1723 (PPTP) and 1721 (L2PT).
            A recent poll suggests that 6 out of 7 dwarfs are not happy

            Comment

            Working...
            X