No announcement yet.

Sporadic connections to 2003 server?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Sporadic connections to 2003 server?

    For some reason I've had users of losing connectivity to the server. I've even had a lost connection and had to reboot my PC to get connectivity back. Yesterday a few people claim that they lost connectivity, gained it back for 10 minutes and then it blipped out on them again and was back. Each time this causes possible lockups of their PC if they are using an application that stores its main files (ACT database for example) on the server. I rebooted the server this morning and have bumped up the Veritas backup which was scheduled for the evening. I don't think it was the backup but it is possible.
    FYI... Just this morning I put the new service pack on it so it wasn't that.

  • #2
    There is a registry key that will keep windows from auto-disconnecting from the server. Set this key on the client and it should resolve your issue.


    Modify the value, or create a new string value, called 'Autodisconnect' and set it to equal the time in minutes before a session is disconnected.

    Restart Windows for the change to take effect.

    Note: Set the value to 0xffffffff to disable the disconnection function.

    Registry Settings
    System Key: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\LanmanServer\
    Value Name: Autodisconnect
    Data Type: REG_DWORD (DWORD Value)
    Value Data: 0 to 4,294,967,295 (0xffffffff) in minutes

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **


    • #3
      Do not think this is related to sessions going into idle state. I'd be checking the logs on the server for any hardware (especially NIC related) errors/warnings.
      Could also be a switch going crazy.

      In any case, just an FYI:
      net config server /AUTODISCONNECT:<time in minutes>
      does the same thing as Anrew's registry hack.
      Guy Teverovsky
      "Smith & Wesson - the original point and click interface"


      • #4
        Ok, I tried the registry change but I couldn't get it to take the setting that you have indicated "0xffffffff". I'm sure it is something I'm doing wrong that I should be smacked in the head for. Anyway, I did find the fix.

        Short version
        The DNS settings were pointing to our ISPs DNS servers and not to the internal DNS. Every once in a while the DNS wasn't working properly and people were losing connection to the server. Changed the DNS from "auto" to the server 1st and outside DNS second. Fixed the problem.

        Long version
        It is the DNS settings on the client machines. I originally started out (months ago) setting the DNS to point to our internal DNS server but then a co-worker had a problem connecting to get his email one day when I was gone. He called the ISP and they finally found the DNS settings and had him change them. This fixed his problem. He asked that we keep them that way so I agreed and forgot about it. The catch of it was that I was logging in through the new server that wasn't setup for everyone else yet. When I had the day off I cut off the new server because I wouldn't be working on it. No server to resolve DNS and it wasn't picking up the secondary DNS. Anyway, we decided to leave it changed until now. Earlier today I had been disconnected and was about to just reboot when I came across another forum with a person having the same problem. He pointed out the fix and it worked without even having to reboot.

        Thanks for the posts!


        • #5
          to disable the autodisconnect:

          net config server /AUTODISCONNECT: -1
          just a comment..
          Technical Consultant

          MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
          "No matter how secure, there is always the human factor."

          "Enjoy life today, tomorrow may never come."
          "If you're going through hell, keep going. ~Winston Churchill"