No announcement yet.

1030 and 1058 userenv errors on one DC. (I have tried everything it seems)

  • Filter
  • Time
  • Show
Clear All
new posts

  • 1030 and 1058 userenv errors on one DC. (I have tried everything it seems)

    I am almost ready to just skip this since I don't notice any issues being caused from this, but it does eat at me that every 5 minutes 4 error messages are being logged in the App log on one of my DCs. Here is a little info about my environment and troubleshooting I have done.

    2 DCs both 2003 w SP1 one configed as PDC emulator; both are GCs.
    1 domain and about 110 client machines and servers total.

    The DC that has the issue is the PDC emulator. Everytime you run gpupdate it logs 2 1030 and 2 1058 userenv errors. Or if you look at the App log it logs every 5 minutes as the pic at the bottom of the page depicts.

    The 1030 errors read:

    Windows cannot query for the list of Group Policy objects. Check the event log for possible messages previously logged by the policy engine that describes the reason for this.

    The 1058 error reads:

    Windows cannot access the file gpt.ini for GPO CN={31B2F340-016D-11D2-945F-00C04FB984F9},CN=Policies,CN=System,DC=xxxxxx,DC=c om. The file must be present at the location <\\\sysvol\\Policies\{31B2F3 40-016D-11D2-945F-00C04FB984F9}\gpt.ini>. (The network path was not found. ). Group Policy processing aborted.

    I have found several articles and threads here that relate to these specific errors; even word for word, but still no luck getting them to go away.

    Most articles suggest permissions/DNS, replication issues. I can access Sysvol from all machines, servers and even the PDC that is reporting these errors. I can even watch files and AD edits replicate just fine between both DCs.

    DNS is updating just fine and nothing else on the network seems wacky. The best MS KB I have found, 839499, can't be completed because I get to step 11 where I go to open the Domain Controller Policy Editor on the emulator DC and get a message stating:

    Failed to open the Group Policy Object. You may not have appropriate rights. DETAILS: The network path was not found.

    I feel like this KB might help, but I can't get past step 11 after spending the good part of a day trying to research that error alone. Obvious some permission is off somewhere, but I cant find it. I CAN open Domain Controller Policy Editor on the other DC.

    I am contemplating installing SP2 just to see what that does.

    Anyone have any other suggestions for me? I REALLY wish I could get a little deeper into the KB article I posted above. That is the only one I have started on and couldn't finish, plus it has the best, word for word description of my issue.

    Last edited by Greg.Allen; 12th August 2008, 14:17.

  • #2
    Re: 1030 and 1058 userenv errors on one DC. (I have tried everything it seems)

    First check your bindings if you have more then one nic in the server.

    Further please review:
    Technical Consultant

    "No matter how secure, there is always the human factor."

    "Enjoy life today, tomorrow may never come."
    "If you're going through hell, keep going. ~Winston Churchill"


    • #3
      Re: 1030 and 1058 userenv errors on one DC. (I have tried everything it seems)

      Hi Greg.Allen,

      I had observed similar problem last month on our second domain controller that is working as a Replication partner. Although the error messges were apprearing constantly however our systems were all running fine.

      Since those event logs were pertaining to Group Policy permission, I thoroughly checked all the Group Policies and found everythging working alright as well. Thus, I did not tamper with the permissions on the SYSVOL folder as that can cause serious problems.

      I happen to browse Mark Minisi's forum on Group Policies on the following link :

      and tried the following:

      "DFSUTIL /PurgeMupCache"

      Our problem disappeared since then.