No announcement yet.

No Security, Sharing, Customize, or "New" tabs on Windows Server 2003

  • Filter
  • Time
  • Show
Clear All
new posts

  • No Security, Sharing, Customize, or "New" tabs on Windows Server 2003

    This site has often been an invaluable source for W2K3 Server issues, so perhaps someone here would be able to help me with the following problem.

    I administer a Windows 2003 Standard (SP2) server that serves as a small office AD/DC, mail server (Exchange 2003), and file server. Few days ago I noticed that various tabs have gone missing from the folder properties. Where normally the tabs "General", "Sharing", "Security", "Web Sharing", and "Customize" tabs are displayed for Administrator, currently only "General" and "Web Sharing" tabs are shown. "Sharing and Security" is also missing from the folder context (right click) menu. Additionally "New" (to create a new folder, shortcut, document, etc.) is gone from the context menu, so when I right click, for example, on the desktop, there is no "New" option in the context menu that pops up. The "New folder" button present in many file save dialogs is also defunct; the button is present but clicking on it does nothing.. no new folder is produced).

    I have combed this forum, Experts Exchange (also posted this there; feel free to copy any solution there if you want EE points ) and elsewhere on the web for a solution and so far nothing has helped. Here's a quick run-down: There are four physical volumes (one of them is a RAID 6 array, the rest are single drives), the filesystem on all of them is and has always been NTFS. I've run chkdsk /r and rebooted. I can view and change permissions using cacls/xcacls/subinacl with no "permission denied" errors. I can also create and delete directories from command line or by using Directory Opus ("File | New" is missing from Explorer). I usually log in to the server via RDC, but logging in at the console doesn't make a difference the problem still persists. The tabs are missing on _all_ folders, regardless on who is the owner, or on which media they're located. The permissions on file "\windows\system32\rshx32.dll" that is sometimes the culprit for missing security tab has the correct permissions and ownership. The server service is running (obviously, since it's a file server).

    I've also created a new user to whom I gave Administrator privileges, then logged in as that user, and the problem still exists... so if it's a registry problem, it's not user specific (though I suppose it could be a wrong default setting). I don't recall making any registry changes for quite some time, so it's unlikely I would have messed up something in the course of regular administration work.

    The system has the most recent 2.x version of ESET nod32 (3.x doesn't support Exchange yet), and I've ran full virus scan so virus attack is unlikely (there is also a perimeter hardware virus shield which makes it less likely for bugs to infect the network in the first place).

    So basically this is a problem with the mentioned options not being displayed in the Folder Properties and in the context menu their associated functions don't seem to be restricted or broken as there are no permission denied or other errors when applying them from command line or from third party applications like Directory Opus.

    Reinstall of the operating system would surely fix the problem, but considering the complexity of the setup I would not venture to do so anytime soon. Even this problem can't be resolved I'd rather rely to cacls/xcacls and Directory Opus to provide the features of the missing tabs even though it makes the administration of the system considerably more cumbersome.

    Thanks for any advice on this issue!

  • #2
    Re: No Security, Sharing, Customize, or "New" tabs on Windows Server 2003

    I had a similar problem with a Windows XP machine that was not displaying the security tab. I ran the following command "regsvr32 rshx32.dll" from the run prompt and the tab appeared.

    I'm not sure if it will work on Server 2003, but it might be worth a try. It worked on the XP machines I had fine though. It might be worth a shot if you down to your last leg.
    MCITP:SA, MCSA 2003, MCP, CCNA, A+, Net+, Security+


    • #3
      Re: No Security, Sharing, Customize, or "New" tabs on Windows Server 2003

      I'd checked the permissions for rshx32.dll but hadn't tried re-register the service and it worked as far as the Security tab is considered which is a good start (thanks boondock!!) Still missing "Sharing" and "Customize" tabs from the folder preferences, and "New" from the context menu. But this must mean that various services that normally would be register have become unregistered for some reason.

      Wonder what the corresponding services are for, for example, Sharing...?

      Though the fact that Security now works already gives me time since I can at least manage the permissions (shares can be created on the command line, but managing the permissions so that they work seem to be tricky on the command line).