Announcement

Collapse
No announcement yet.

BIND slave to Win2003 DNS?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • BIND slave to Win2003 DNS?

    I've setup BIND on FreeBSD and want it to be a secondary DNS for the two Windows DNS servers I already have setup. I'm using it as my DNS for Vista, but the logs reveal that the zone transfer are not working from Win2003. I've already verified that the FreeBSD server is listed as a name server for both Win2003 DNS servers. What do I need to do to fix the errors below?

    May 14 15:08:14 FreeBSD named[610]: zone advocacyinc.org/IN: gc._msdcs.advocacyinc.org/A: bad owner name (check-names)
    May 14 15:08:14 FreeBSD named[610]: zone advocacyinc.org/IN: gc._msdcs.advocacyinc.org/A: bad owner name (check-names)
    May 14 15:08:14 FreeBSD named[610]: dumping master file: master/tmp-XA067EFjgx: open: permission denied
    May 14 15:08:14 FreeBSD named[610]: transfer of 'advocacyinc.org/IN' from 192.168.100.2#53: failed while receiving responses: permission denied
    May 14 15:54:22 FreeBSD named[610]: transfer of '100.168.192.in-addr.arpa/IN' from 192.168.100.2#53: failed while receiving responses: REFUSED

  • #2
    Re: BIND slave to Win2003 DNS?

    Try allowing by IP instead of NS entry?

    Comment


    • #3
      Re: BIND slave to Win2003 DNS?

      If you're talking about from the Windows side, the only way you can add a Name Server is with FQDN and IP address. You can't leave the name portion out.

      Comment


      • #4
        Re: BIND slave to Win2003 DNS?

        Where do you see this?

        Right click a Zone > Properties, Zone Transfers tab...

        Comment


        • #5
          Re: BIND slave to Win2003 DNS?

          When I go to Zone Transfers I have the option checked that says "Only Servers listed on the Name Servers tab". Under the name servers tab I have the FreeBSD server name and IP address because it won't just take the ip address. I did notice that there is another option under Zone Transfers called "Notify..." which allows you to specify secondary servers by IP address. Maybe I'll try that.

          Comment

          Working...
          X