No announcement yet.

Dcom+ access errors

  • Filter
  • Time
  • Show
Clear All
new posts

  • Dcom+ access errors

    Hi Folks

    I really need some help as I'm running out of things to try. I have a windows 2003 X64 sp2 box with 2 quad core 2.4 cpus and 16 gig of ram which is running as a terminal server for our remote customers.

    I was force to restart the server after one of our in house apps hung and locked out loads of files, folders etc this happens quite a lot and after the reboot the everyone was able to get back in.

    I went into IIS to check if I'd installed internet printing and I found that the iis mmc was takeing ages to come up, when it did finally show it wouldn't connect to IIS, I checked and I found that all the services where running and that I was able to ftp into the box.

    I then tried to access add remove windows components and found that it took nearly 8 minutes to come up and the population of add remove programs took a similar time and box is using 2% cpu and 900 meg of ram.

    Checking the logs I found some GUIDs unable to register the Dcom so I went in to component services to check the permissions and saw a red arrow beside my computer, when I tried to get acess to Com+ application I get the following.

    Error code 80110823 saying " the specified user does not have access to write to the sytem registry" I get the same thing when local admin, domain admin etc.

    I reinstalled dcom, disabled and enabled it in the registry and tried everything I can find on the web which was help resolve the issues ith the speed I can access add remove programs and windows components but I'm still getting the sam error in component services.

    If anyone can help it would be much appreciated.


  • #2
    Re: Dcom+ access errors


    Some good news I've managed to get IIS running again after registering serveral dlls for both the 32 bit and 64 bit version of the files, and then reinstalling IIs one part at a time

    Also thanks to regmon I can see that svchost is being denied access to HKCR\CLSID which is why I get the registry error in component manager. I've tried setting the permissions on the key to give the local service account full access but I still get access denied in regmon.

    Any ideas?



    • #3
      Re: Dcom+ access errors

      Just thought I post a screen dump of the permissions for the registry key I'm getting the access denied message from, hope this helps all the big brains out there.

      Attached Files


      • #4
        Re: Dcom+ access errors

        Another update, I was having the same dcom problems with another 2003 box however after following an MS article about repairing windows updates and after registering various dll’s and reinstalling iis I was able to get dcom working again.

        However, yesterday users started getting access denied, the file is in use when trying to delete files, installing applications on the server I’d get access denied trying to write to c:\program files\etc, when I’m logged in as administrator. I had to reboot the server to resolve it. Now this was one of the problems I was getting when dcom had failed but dcom is now working and I’m still getting this error so I’m not really sure what to do next.

        I have scanned both boxes with McAfee and trend online scan and found no viruses or malware.

        Has anyone got any ideas?