No announcement yet.

TCP/IP error in windows xp home

  • Filter
  • Time
  • Show
Clear All
new posts

  • TCP/IP error in windows xp home

    The problem I am having with a computer I'm working on is this:

    It will dial-up and connect to the internet, it is able to ping numeric IP addresses, but not hostnames. Internet Explorer gives the error no page to display when you try to use it. I have attached it to a network, and still get the same problem, I can ping numeric IP addresses, but not hostnames.

    Things I have tried:

    Tried the netsh utility to reset TCP/IP settings
    Tried reinstalling IE 6.0
    Tried remaking the Dial-up connection
    The customer has no restore points so I can't do a system restore..

    If you have any ideas on what may resolve this problem it would be much appreciated.


  • #2
    Try NSLOOKUP and tell us what you find.

    Daniel Petri
    Microsoft Most Valuable Professional - Active Directory Directory Services


    • #3
      NSLOOKUP results

      Running NSLOOKUP came back with this output

      Can't find server name for address:
      Can't find server name for address:
      Default servers are not available
      Default server: Unknown


      • #4
        Re: NSLOOKUP results

        DNS is your problem. to check, run NSLOOKUP and after the results you displayed type a dns name such as if i am right you will not get a result. If this is the case then edit the TCP/IP settings and manually input a valid DNS server address.


        • #5
          Problem was resolved...

          I did manually put in a valid DNS server, two of 'em in fact, what ended up fixing the problem was a utility that completely reset tcp/ip settings.

          For some reason netsh didn't do it good enough, but once i ran that utility (for the life of me I can't remember what it was called) the internet worked fine


          • #6
            More than likely your Winsock settings were screwed. Re-Installing TCP/IP usually takes care of it.

            For future reference to all, a handy little tool at this site should resolve those pesky Winsock problems.



            • #7
              I had the same issue with a Windows 98se system. Could only go on the net as long as I used the ip (google). I knew because of my lack of name resolustion that DNS was the problem. I tried uninstalling TCP/IP and even the adapter and Client. Still had no luck so I took it a step farther and removed Winsock from the regisrty. There are 2 keys in the registry...
              HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\W inSock
              HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\W inSock2

              Backup these keys first just in case. I then restarted and reinstalled the client/adapter/protocol and had no more problems. Microsoft has a post in the KB on the issue but I can find it anymore. The KB referenced the issuse as "a corrupt TCP/IP Stack"
              Brad Bentley