No announcement yet.

WSUS 3: ASP Modules suddenly stop working

  • Filter
  • Time
  • Show
Clear All
new posts

  • WSUS 3: ASP Modules suddenly stop working

    I just set up a fresh Win2k3 SP2 server. The machine is a new Member Server on our domain. On it, I installed WSUS 3 and all the prerequisites. WSUS was running fine for a week. This morning I come in and find that the Admin console was broken.

    The Application Log contains a number of messages. WSUS Event ID 7053 says you should try removing the preferences file at %AppData%\Microsoft\MMC\, which I did. This allows the Admin console to open...albeit empty. I try to get it to connect to a server, whether this one or our pre-existing one that still runs. It fails to connect to itself or the other server whether I choose to connect with SSL or not.

    The Application Log also records Event ID's 12002, 12012, 12022, 12032, 12042 and 12052 from WSUS, which state that each of these Web components are not working.

    An almost equal number of Event ID 1310 messages appear from ASP.NET, which contain the following text.
    Event Type: Warning
    Event Source: ASP.NET 2.0.50727.0
    Event Category: Web Event
    Event ID: 1310
    Date: 1/11/2008
    Time: 10:54:24 AM
    User: N/A
    Computer: ACS04
    Event code: 3007
    Event message: A compilation error has occurred.
    Event time: 1/11/2008 10:54:24 AM
    Event time (UTC): 1/11/2008 7:54:24 PM
    Event ID: 33503726763844c784ec30c25201b53b
    Event sequence: 3
    Event occurrence: 1
    Event detail code: 0

    Application information:
    Application domain: /LM/W3SVC/1/ROOT/ApiRemoting30-17-128445548637031250
    Trust level: Full
    Application Virtual Path: /ApiRemoting30
    Application Path: c:\Program Files\Update Services\WebServices\ApiRemoting30\
    Machine name: ACS04

    Process information:
    Process ID: 3768
    Process name: w3wp.exe

    Exception information:
    Exception type: HttpCompileException
    Exception message: (0): error CS0016: Could not write to output file 'c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Tem porary ASP.NET Files\apiremoting30\c6645651\8ff8bbee\App_global.a sax.nuq9phuj.dll' -- 'Access is denied. '

    Request information:
    Request URL: http://acs04/ApiRemoting30/WebService.asmx
    Request path: /ApiRemoting30/WebService.asmx
    User host address:
    Is authenticated: False
    Authentication Type:
    Thread account name: NT AUTHORITY\NETWORK SERVICE

    Thread information:
    Thread ID: 1
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace: at System.Web.Compilation.AssemblyBuilder.Compile()
    at System.Web.Compilation.BuildProvidersCompiler.Perf ormBuild()
    at System.Web.Compilation.ApplicationBuildProvider.Ge tGlobalAsaxBuildResult(Boolean isPrecompiledApp)
    at System.Web.Compilation.BuildManager.CompileGlobalA sax()
    at System.Web.Compilation.BuildManager.EnsureTopLevel FilesCompiled()
    at System.Web.Hosting.HostingEnvironment.Initialize(A pplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)

    Custom event details:

    For more information, see Help and Support Center at

    As a troubleshooting measure, and only so drastic because the server is new, I completely uninstalled WSUS 3, IIS, ASP.NET and .Net Framework 2. After reinstalling, no change. Restarting the affected services has no effect. Restarting the server has no effect.

    What annoys me is that the server was running normally. Then it decides not to run. No one touched the server for two days.

    Any suggestions? Google and Microsoft aren't getting me far.