No announcement yet.

Unable to access with the CNAME

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to access with the CNAME

    Env. Details:

    1. Windows 2003 EE with SP2
    2. AD integrated DNS
    3. Domain Name:


    If I try to access \\ that works fine but there is some application which needs to access the same share with a flat name (e.g. \\myshare).

    So I created a DNS alias "myshare" to point Now if i ping "myshare" it pings with the right IP address so name resolution is working fine but when I try to access the share \\myshare it prompts me for user name and password. I tried to specify username in each possible format (e.g. [email protected]l, abc\user,\user, simple user name) but it says bad username and password. Believe me user name and password is correct and user is domain admin. It works fine if I try to access \\ or with IP address.

    Kapil Sharma
    Life is too short, Enjoy It.

  • #2
    Re: Unable to access with the CNAME

    Set up WINS?
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    IT Trainer / Consultant
    Ossian Ltd

    ** Remember to give credit where credit is due and leave reputation points where appropriate **


    • #3
      Re: Unable to access with the CNAME

      I hope this helps you: "Connecting to SMB share on a Windows 2000-based computer or a Windows Server 2003-based computer may not work with an alias name".

      Add a new DWORD to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\LanmanServer\Parameters called DisableStrictNameChecking
      and set its value to 1.

      I am told this works, for your situation, but I have not tried it. Can you let us know if it has worked for you please?
      Best wishes,
      MCP:Server 2003; MCITP:Server 2008; MCTS: SBS2008


      • #4
        Re: Unable to access with the CNAME

        I go with Tom.
        Wins is still needed in many occasions.
        Technical Consultant

        MCITP(EA, SA), MCSA/E 2003:Security, CCNA, SNAF, DCUCI, CCSA/E/E+ (R60), VCP4/5, NCDA, NCIE - SAN, NCIE - BR, EMCPE
        "No matter how secure, there is always the human factor."

        "Enjoy life today, tomorrow may never come."
        "If you're going through hell, keep going. ~Winston Churchill"


        • #5
          Re: Unable to access with the CNAME

          PaulH is correct regarding this issue and the link he provided is the appropriate fix. I've had to do this on W2K3. The server is not "listening" for the name referenced in the CNAME record and says "that's not me" and so therefore does not respond. After the change referenced in the link the server says "that is me" and responds.


          • #6
            Re: Unable to access with the CNAME

            Thanks a lot to all of you.....

            1. WINS was already in place.

            2. It started working once I made the change suggested by "PaulH".

            Kapil Sharma
            Life is too short, Enjoy It.