Announcement

Collapse
No announcement yet.

Enabling SIS in Storage Server 2003

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Enabling SIS in Storage Server 2003

    I am attempting to enable Single Instance Storage on a Windows Storage Server 2003 R2 64bit.

    This is a clean install of the OS (by me not the OEM). I have installed Single Instance Storage in add/remove and installed all updates.

    From there I am supposed to run sisadmin.exe from the command line to enable the service but for some reason the command line says that this is an invalid command. I also do not have the advanced tab when I look at a non system volume properties. The Single Instance Storage Groveler is however listed in services. It errors when attempting to start from the GUI (as it should).

    After searching the system there is in fact no sisadmin.exe file. I have uninstalled and reinstalled the single instance storage option several times.

    There seems to be very little documentation about this version of 2003. I haven't seen anything about this not being support in 64bit. Thinking about reinstalling the OS if I can't find a solution soon but I really don't want to. I am hoping someone here has an idea.

    Thanks in advance

  • #2
    Re: Enabling SIS in Storage Server 2003

    I don't think it's the 64-bit part you have a problem with - the 64-bit version is, I believe, functionally identical to the 32-bit version. I think the part you are having issues with is the R2 vs. non-R2.

    AFAIK, in non-R2 Windows Server 2003, you cannot use SIS unless you install RIS - RIS is the enabler and the only application which uses it. Are you sure that, in R2, you can install SIS and use it WITHOUT installing RIS?


    Tom
    For my own and your protection, I do not provide support by private message under any circumstances. All such messages will be deleted and ignored.

    Anything you say will be misquoted and used against you

    Comment


    • #3
      Re: Enabling SIS in Storage Server 2003

      MS white papers point out that you can install/enable SIS without installing RIS. R1 did not support SIS by default without RIS. This is really the only reason I went with Storage Server. I have triple checked that I am on R2.

      Out of the few sites with info on enabling SIS this one states the process. I even tried to install NFS support since he had it checked in his screenshot... no luck with that either. Services claims no dependecies for the sis service.

      link

      I doubt 64 bit is the problem either but I thought I would throw it out there... Backup exec 10d will not run in 64 bit but that is another issue.

      Comment


      • #4
        Re: Enabling SIS in Storage Server 2003

        Have you installed the Support Tools and Resource Kit?


        Tom
        For my own and your protection, I do not provide support by private message under any circumstances. All such messages will be deleted and ignored.

        Anything you say will be misquoted and used against you

        Comment


        • #5
          Re: Enabling SIS in Storage Server 2003

          I did not install those... that was a very good idea and as I did it I thought it was going to work but it didn't.

          Good news though it got me to thinking and I found the solution.

          I searched both CDs for "sis" and there is a sisadmin.ex_ file

          I expanded that at the command line then change the name to .exe and ran that. It is now working.

          It would have taken me a while to come across that if you hadn't mentioned the support tools.

          Thanks for your help!
          Last edited by DamonG; 10th January 2008, 23:25.

          Comment


          • #6
            Re: Enabling SIS in Storage Server 2003

            Hey, no worries, glad you found it


            Tom
            For my own and your protection, I do not provide support by private message under any circumstances. All such messages will be deleted and ignored.

            Anything you say will be misquoted and used against you

            Comment

            Working...
            X