No announcement yet.

Server unable to "net send" any machine

  • Filter
  • Time
  • Show
Clear All
new posts

  • Server unable to "net send" any machine

    I have a server that is not able to "net send" any machine. It is running Windows 2003 server and has the messenger service disabled so that it does not receive any incoming "net send" messages. However there is another server that also has the messenger service disabled and can net send out.

    Reason I need this: Users run processes on the servers and have these commands at the end of their batch files to let them know when their process has finished.

    I have checked all the services manually and the working server does not have any service the broken one does not have. There were a couple of things in netdiag however that I do not quite understand
            NetBT name test. . . . . . : Passed
            [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names is missing.
    NetBT transports test. . . . . . . : Passed
        List of NetBt transports currently configured:
        1 NetBt transport currently configured.
    NetBT name test. . . . . . . . . . : Passed
        [WARNING] You don't have a single interface with the <00> 'WorkStation Service', <03> 'Messenger Service', <20> 'WINS' names defined.
    DNS test . . . . . . . . . . . . . : Passed
              [WARNING] Cannot find a primary authoritative DNS server for the name
                ''. [RCODE_SERVER_FAILURE]
                The name '' may not be registered in DNS.
    I suspect I have these NBT warning because the messenger service is disabled, they were not on the working server when I ran netdiag on it but it also has the service disabled. Both servers rebooted on Wednesday at the same time.

    I have run nbtstat against both servers and can see the missing name is the 03 messenger service name on the non-working server.

    The dns error is a bit perplexing too since I have manually queried every dns server in the list that the non-working server uses. Queries for the as well as just servername, both forward and reverse, came back successful every single time I queried any of the dns servers, so I don't know what this is really complaining about.

    The working server has not had any of these messages in it's netdiag which passed everything.
    I have even gone through the network settings, making sure netbios over tcp is enabled and that the dns and wins server settings are identical.

    I've done ipconfig/flushdns and nbtstat -RR and nbtstat -R but still no joy.

    Can anyone please give me some ideas on things to do here, I'm running out...?

  • #2
    Re: Server unable to &quot;net send&quot; any machine

    Had an issue with Net Send before but turns out simple administration fix.

    1. Turn Back on Messenger Services for all machines.
    (Not quite sure how net send is running on a system without this service activated but it is essential to run the Net Send command Send and Receive. This service must be activated on the source and destination machine. Find it best to activate this service through GPO if your using a windows domain. If security through this is an issue then control this through the Windows Firewall settings)

    If still not functioning....

    2. Check Windows Firewall is not already blocking any services. Again only if its not a security issue, temporarily turn off windows firewall. If the Net Send Command works, enable each block one by one till you see which rule is stopping the Net Send function and ammend accordingly.

    3. Also check the ICMP Properties too. Make sure Echo request is enabled on destination machine and test you can ping by "Machine Name" rather than IP.

    If you cant ping by "Machine Name" then you have a different problem all together and id need all network info to put together a scenario. I.e Amount of Servers, ip configs, roles and servies running and client configs.

    Let me know how you get on...



    • #3
      Re: Server unable to &quot;net send&quot; any machine

      it was missing the netbios 03 record. This was the only difference. I started the messegner service, the record got created, then stopped it again and tried again.

      net send works after that even though the messenger and alerter services are off.



      • #4
        Re: Server unable to &quot;net send&quot; any machine


        Out of curiosity im trying that out on my own network now. Cant get that to work. Tried it out on both Win 2003 R2 SP2, and Win XPPro SP2. Dont doubt its not working for you know but will it stay functioning for you even after a restart? Might be worth the try to see?

        ....Scratch that. Maybe "if it works dont fix it" policy is best!
        Last edited by Chin up!; 12th December 2007, 21:46.