Announcement

Collapse
No announcement yet.

XP share not working with non-admin users

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • XP share not working with non-admin users

    I thought I had all this figured out.

    I'm sharing a directory on my PC (software that I can install on other PCs) I am server administrator.
    I can not get access to my shared folder (XP) from other computers that are not network administrators (yes they are admins on their own PC)

    I have no restrictions on the share. It is shared for Everyone, and full read and write capabilities, but only Administrators can view the contents.

    I also have a folder on my share server (just XP PC with shared outlook calender) and some users can see the contents but other users can't even see the shared folder much less access it. It isn't being consistent or logical. Can anyone tell me where to start or what to look for?
    I already know I'm not that bright. Please be constructive. Only give your 2cents if it helps. Don't be condesending or demeaning. It doesn't make you look smart. You just look like an arse.
    Chris Robertson
    The Computer Doctor

  • #2
    Re: XP share not working with non-admin users

    Could you please post the SHARE PERMISSIONS and the NTFS PERMISSIONS in total here?


    Tom
    For my own and your protection, I do not provide support by private message under any circumstances. All such messages will be deleted and ignored.

    Anything you say will be misquoted and used against you

    Comment


    • #3
      Re: XP share not working with non-admin users

      This might be a possible solution to your problem

      1 Right click the folder you shared to the other users
      2 Click The permissions tab
      3 Click Add
      4 Click the location button
      5 Then HighLight the local computer and press enter
      6 Enter the local account , press Check Names
      7 Click allow full control
      8 Click OK

      Part 2

      1 Stay in the folder properties
      2 Click the Security Tab
      3 Then click ADD , Add Everyone group, make sure the location is set to the local computer

      4 High Light the everyone group , click full control or the level of permission you want the other admins to have.

      5 Click Apply , Click OK

      After you have followed the steps the admins should see the files.

      Comment


      • #4
        XP users not able to browse workgroup computers. (domain & server 2003)

        working Backwards here;
        Turner - Thanks, but all those are on already. The admin can already see the folder, only the General User can not.

        Stonelaughter - Share premission and NTFS permission from where?

        Let me add this little bit too. I've notices that none of the General users can see shared folders & they can not remote desktop into other computers (this is fine except when I'm on someones pc and need to remote in to the server)

        I actually never even get to see the share folder. It will not let me browse the computer! It tells me I don't have the rights. I'm figuring that this is a domain security issue.
        (I've not changed any setting and they used to be able to browse shared folders)

        So the issue really is, users not able to browse workgroup computers.

        Thanks for all your help guys!



        A little more clari-fonication, I'm running server 2003 w AD & a domain.
        I already know I'm not that bright. Please be constructive. Only give your 2cents if it helps. Don't be condesending or demeaning. It doesn't make you look smart. You just look like an arse.
        Chris Robertson
        The Computer Doctor

        Comment


        • #5
          share folder rights

          Where are the share folder rights dictated at?
          Is it at the PC that is share the folder for from the server side?

          To reiterate I can share a folder on a pc and only admins can access it, not regular users. I tried are the rights on the share folder and include Everyone, but regular users still can not access.
          I already know I'm not that bright. Please be constructive. Only give your 2cents if it helps. Don't be condesending or demeaning. It doesn't make you look smart. You just look like an arse.
          Chris Robertson
          The Computer Doctor

          Comment


          • #6
            Re: XP share not working with non-admin users

            It sounds like you need to look at the "access this computer from the network" user right on your machine to make sure that the users or groups have this right. This can be found in the Local Security Policy from Administrative Tools.

            Comment


            • #7
              Re: XP share not working with non-admin users

              1. Share Permissions and NTFS Permissions are set on the folder itself; right-click the folder, select "Properties" and then choose the "Security" tab for NTFS Permissions, and the "Sharing" tab, "Permissions" button for Share Permissions.

              2. If you don't see a "Security" tab, and you're using Windows XP Pro, then in Windows Explorer select "Tools, Options", choose the "View" tab, scroll to the bottom, and DESELECT "Use Simple File Sharing (Recommended)". Then try Step One again.

              3. If you are using Windows XP Home, forget it; this is how it is.

              Let me know what you have in the Sharing and Security tabs for the shared folder and we can go from there.


              Tom
              For my own and your protection, I do not provide support by private message under any circumstances. All such messages will be deleted and ignored.

              Anything you say will be misquoted and used against you

              Comment


              • #8
                Re: XP share not working with non-admin users

                As regards the "Unable to browse workgroup computers" thing; is this a domain or a workgroup? If it's a domain, you need to check your Group Policies for the setting JoeQwerty mentioned, and ensure that "Domain Users" have the "Access this computer from the network" right. Also make sure that only Guests have the "Deny access to this computer over the network" right.


                Tom
                For my own and your protection, I do not provide support by private message under any circumstances. All such messages will be deleted and ignored.

                Anything you say will be misquoted and used against you

                Comment


                • #9
                  XP share not working with non-admin users -followup

                  I reinstall the os on the computer I was having problems with. As it turnes out the auto os installation disk I created removed a service or something vital to network/domain browsing. I'm not even sure what it was.

                  I updated this auto install disk with no removals and only automated some things and it works fine. I can browse the network/domain etc.
                  I already know I'm not that bright. Please be constructive. Only give your 2cents if it helps. Don't be condesending or demeaning. It doesn't make you look smart. You just look like an arse.
                  Chris Robertson
                  The Computer Doctor

                  Comment

                  Working...
                  X