No announcement yet.

Adprep Error while trying to Add a Win2k3 r2 to Win2K Domain

  • Filter
  • Time
  • Show
Clear All
new posts

  • Adprep Error while trying to Add a Win2k3 r2 to Win2K Domain

    Hi I am trying to add a new win2k3 r2 to my win2k group of servers and have encounter the following errors:

    Adprep verified the state of operation cn=ad3c7909-b154-4c16-8bf7-2c3a7870bb3d,cn=Operations,cn=ForestUpdates,CN=Con figuration,DC=portrust,DC=com.


    The operation has not run or is not currently running. It will be run next.

    Adprep was about to call the following LDAP API. ldap_modify_s(). The entry to modify is CN=Group-Policy-Container,CN=Schema,CN=Configuration,DC=portrust,D C=com.

    LDAP API ldap_modify_s() finished, return code is 0x33

    ADPREP was unable to modify the default security descriptor on object CN=Group-Policy-Container,CN=Schema,CN=Configuration,DC=portrust,D C=com.


    Adprep attempts to merge the existing default security descriptors with the new access control entry (ACE).

    [User Action]

    Check the log file Adprep.log in the system root System32\Debug\Adprep\Logs directory for more information.

    Adprep encountered an LDAP error.

    Error code: 0x33. Server extended error code: 0x20d9, Server error message: 000020D9: SvcErr: DSID-030A05F8, problem 5001 (BUSY), data 33

    Adprep set the value of registry key System\CurrentControlSet\Services\NTDS\Parameters\ Schema Update Allowed to 1

    Adprep was unable to update forest-wide information.


    Adprep requires access to existing forest-wide information from the schema master in order to complete this operation.

    [User Action]

    Check the log file, Adprep.log, in the C:\WINNT\system32\debug\adprep\logs\20070718141932 directory for more information.

    I have 3 old servers that i am planning to decomission and migrated them to the new win2k3 servers. After i ran adprep the above errors appear. 2 of the servers are ad and the 3th is a exchange 5.5 server.


  • #2
    Re: Adprep Error while trying to Add a Win2k3 r2 to Win2K Domain

    This is R2.. Are you running the adprep from CD2????

    Steven Teiger [SBS-MVP(2003-2009)]
    Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

    We donít stop playing because we grow old, we grow old because we stop playing.


    • #3
      Re: Adprep Error while trying to Add a Win2k3 r2 to Win2K Domain

      yup i was running the adprerp from the r2 disc 2 on my win2k ad.

      at first it wouldn't run as the the exchange cause some issue but i ran the script posted on MS Website and that was resolve till this error mention above