No announcement yet.

Dcdiag/Netdiag Failures

  • Filter
  • Time
  • Show
Clear All
new posts

  • Dcdiag/Netdiag Failures

    Hi, I've been upgrading one of our DC's to Windows Server 2003 following the "sticky" thread about this process I have ran into some issues with Dcdiag/Netdiag failures. I was wondering if anyone had any feedback...

    Some more information:

    SERVER1 is the old Windows Server 2000 DC
    SERVER0 is the new Windows Server 2003 DC

    On the new Server 2003 box (SERVER0):

    netdiag passes every test except:

    Domain Membership Test: failed
    [WARNING] The system volume has not been completely replicated to the local machine. This machine is not working properly as a DC.

    dcdiag passes all tests except:

    Unable to to connect to the NETLOGON Share! (\\SERVER0\netlogon)
    [SERVER0] A net use or LsaPolicy failed with the error 1203, No network provider accepted the given network path.

    Warning: DsGetDcName returned information for \\SERVER1.x.x when we are trying to reach SERVER0.
    Server is not responding or is not considered suitable.

    I ran adprep /forestprep and /domainprep prior to promoting the new DC into the network, (Windows 2000 Native functional level domain).

    I tried running dcdiag /fix and netdiag /fix and restarting the netlogon service.

    I've tried changing the Primary and Secondary DNS addresses on the interfaces, demoting the new server and rejoining it to the domain. So far I can't get the errors to go away.

    I've checked the zone transfer properties and all the SRV records are present on both servers. I've read and try'd most everything in Microsoft's Support Pages. Any suggestions on what's wrong? Or maybe how DNS may be setup incorrectly...

  • #2
    Re: Dcdiag/Netdiag Failures

    I seemed to have fixed the problem! So for anyone who runs into this issue edit your registry key on the working DC:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\NtFrs\Parameters\Backup\Restore\Process at Startup

    the global BurFlags registry key contains REG_DWORD values and needs to be changed to D4.

    After restarting the netlogon and ntfrs services the Sysvol and Netlogon shares immediately appeared on the new server and I created a test file and it immediately replicated to the new server!

    All tests in dcdiag and netdiag pass now..

    Time to move onto the next part of the upgrade phase
    Last edited by Tyl0r; 14th May 2007, 23:16.