Announcement

Collapse
No announcement yet.

Sever 2003 AD Net use problem

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sever 2003 AD Net use problem

    Pls help me

    >net use lpt1 \\test\Hplaserj

    The password is invalid for \\test\Hplaserj.

    Enter the user name for 'test': test
    Enter the password for test: test
    System error 5 has occurred.

    Access is denied.
    Last edited by kursad; 8th May 2007, 08:43.

  • #2
    Re: Sever 2003 AD Net use problem

    Don't let us guess to much.
    Describe the situation -> what, where and how. Who is logged-on?
    Client os, domainnetwork?
    And ask a clear question (that ends with a question mark).

    nb. If the printer is on the server that is member of a domain, then you should of course provide also the domainname\ with the username!

    \Rems

    This posting is provided "AS IS" with no warranties, and confers no rights.

    __________________

    ** Remember to give credit where credit's due **
    and leave Reputation Points for meaningful posts

    Comment


    • #3
      Re: Sever 2003 AD Net use problem

      I am creat AD domayiin contrelloer.
      i ma creat net use lpt1: \\Noreplay\Hplasej
      reguest username and password but i add user name and password.
      reguset incorrect.
      next -- I am add user domain admin groups and user connect printer
      domain user not connect printer

      Comment


      • #4
        Re: Sever 2003 AD Net use problem

        hi kursad,

        The reason for this issue is because in Windows XP and Windows Server 2003, non-administrators cannot remap an LPT port to a network printer, when the LPT port is already assigned to the local parallel port. In other words, only a member of the Administrators group can use the net use command tomap the LPT port for a local (hardware) parallel port to a network printer. According to Microsoft, this behaviour is desinged to help improve security.


        To solve the cannot net use lpt1 problem, you can use one of the these ways:
        1. Log on as an administrator
        2. Use the devcon disable *PNP0401 command to disable the LPT port mapping to the local parallel port when the computer starts. The devcon disable *PNP0401 command is for LPT1. To find the hardware ID for other LPT ports, use the devcon findall * command. The devcon command must run when the computer starts. For a computer in a domain, you can set up Group Policy to run devcon as a computer startup script. To set Group Policy, open the appropriate group policy, open Computer Configuration\Windows Settings\Scripts (Startup/Shutdown)\Startup, and then add the command. Alternatively, the command can be run individually at each workstation by adding a command to Startup folder for All Users or particular users. Devcon utility can be found here with its information.
        3. If your program can print to the LPT2 port or the LPT3 port, use the net use command to map the network printer to the LPT2 port or the LPT3 port. Most computers do not have physical LPT2 or LPT3 ports, so a non-administrator can map an LPT2 port or an LPT3 port to a network printer.
        (from: http://www.mydigitallife.info/2005/1...n-windows-xp/)

        \Rems

        This posting is provided "AS IS" with no warranties, and confers no rights.

        __________________

        ** Remember to give credit where credit's due **
        and leave Reputation Points for meaningful posts

        Comment


        • #5
          Re: Sever 2003 AD Net use problem

          Thanks

          I am test this tools. your answer is coreect.

          but i cant disable devcon disable lpt*
          I am creat user logon\logof script but lpt port can't disable


          devcon disable LPT*

          net use lpt1: \\mobile\hp /user:\Administrator 123456

          net use K: \\172.16.1.110\Nalog /user:\beta 1

          Comment


          • #6
            Re: Sever 2003 AD Net use problem

            Re-mapping the LPT1 port must be done in two steps
            1. disable the fysical LPT1 port during the computer startup (=before the logonscreen appears).
            2. Map LPT1 to the networkprinter during user logon (=after the logonscreen).

            Copy the batch below (disableLPT1.cmd) to a new folder IN the "NetLogon" share
            (in the batch-file it self you can read what to do with it)
            Code:
            @Goto disableLPT1.cmd
            REM Non-administrators cannot remap an LPT port to a network printer
            REM - http://support.microsoft.com/kb/313644 -
            
            :---------------------------------------------------------------------------
            :PART 1
            
            REM Download and expand DevCon  -from-
            REM "http://support.microsoft.com/kb/311272"
            
            REM Create a subfolder in the "netlogon" share on a Domain Controler
            REM give that folders this name "StartupScripts"
            REM give the "ALL USERS" group permissions to this folder 
            
            REM Create this batch (disableLPT1.cmd) in the folder StartupScripts
            
               :disableLPT1.cmd
               @Echo off
               Set ScriptPath="%0\..\"
               %ScriptPath%\Utils\devcon.exe disable  *PNP0401
            
               Goto :eof
            
            REM next - create the subfolder "StartupScripts\Utils"
            REM now copy the expanded file devcon.exe from i386\ to the 
            REM newly created subfolder "StartupScripts\Utils\" in the netlogonshare.
            
            
            :---------------------------------------------------------------------------
            :PART 2
            
            REM The batch (disableLPT1.cmd) must be applied to computers (not to users)!,
            REM there for execute this batch as a startup script using the GPO linked to
            REM the OU containing the computers.
            REM edit - (Computer Configuration\Windows Settings\Scripts (Startup/Shutdown)\Startup)
            
            REM The batch now will be executed during every startup of the client computer
            
            REM (For disabling other LPT-ports fysically exists on client computers, see
            REM  http://www.jsifaq.com/SF/Tips/Tip.aspx?id=4703 )
            
            
            REM After that... you can create
            REM a normal Logon script (applied to users) to map the port LPT1 to the network printer,
            REM - *without* the name and password request comming-up this time -


            user logon script:

            :re-map LPT1 to networkprinter
            Start/w /B Net use LPT1: /delete
            Net Use LPT1: \\mobile\hp /persistent:no

            :map K: drive to networkshare
            Start/w /B Net use K: /delete
            net use K: \\172.16.1.110\Nalog /persistent:no



            \Rems
            Last edited by Rems; 14th May 2007, 17:27. Reason: typos

            This posting is provided "AS IS" with no warranties, and confers no rights.

            __________________

            ** Remember to give credit where credit's due **
            and leave Reputation Points for meaningful posts

            Comment


            • #7
              Re: Sever 2003 AD Net use problem

              Thanks

              I am disable local computer LPT Port and creat new script.

              This is very good answer.

              Thanks

              Comment

              Working...
              X