No announcement yet.

Terminal Server Login Problem--Details Inside

  • Filter
  • Time
  • Show
Clear All
new posts

  • Terminal Server Login Problem--Details Inside

    I demoted a domain controller to a member server and now the Terminal Server is FUBAR. I uninstalled it and reinstalled it twice to no avail. Everytime a non-administrator logs in, I get this error message:

    "The local policy of this system does not allow user to log in interactively." I went to TS Connection and set the users up with permissions to use the server and I still get this error. I have the TS set up in Remote Administration mode because only two users need access and I don't want to deal with licensing. Secondly, this method works on other Terminal Servers as well (although those ones are domain controllers).

    What have I overlooked? I've tried everything I know how to fix th is problem.

  • #2
    Re: Terminal Server Login Problem--Details Inside

    You've impacted logon rights somehow.

    Run GPEDIT.MSC on the server
    Then check your local security policies, user rights assignments - the answer will be in there.

    Note that although you can make changes using gpedit.msc, the areas above may also be configured from a GPO in your organization.
    VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+ - VMware Virtualization Evangelist
    My advice has no warranties. Follow at your own risk.


    • #3
      Re: Terminal Server Login Problem--Details Inside

      Thanks for the reply. The users can log into other Terminal servers in the domain with no problem. However, with this server only local or domain admins can log in locally. I checked the Group Policy stuff and nothing is out of the ordinary.

      The only solution seems to be giving the users admin rights.

      The probable cause to this anomaly is a failed DC promotion that happened a few months ago. We tried to promote the server to a DC but when we did, the SAM database got screwed up after a few moments and the DHCP and DNS services bombed out. So we demoted the server to member status and ever since then, I get that error when logging in.

      If I put the domain user in the local administrators group, he or she can log in with no problem.


      • #4
        Re: Terminal Server Login Problem--Details Inside

        Did you add the users or their group to the "remote desktop users group"?
        Administrators are already added to this group, and that's why you could log in.
        In my opinion



        • #5
          Re: Terminal Server Login Problem--Details Inside

          Open Local Security Policy on that Server,
          Security Settings->Users Rights Assignment-> Check all issues with logon Locally and so.
          Thanks & Regards


          Computer Science Graduate