No announcement yet.

SBS 2003. Assistance with System Restore

  • Filter
  • Time
  • Show
Clear All
new posts

  • SBS 2003. Assistance with System Restore

    Hello people, This is my first post on this website, although has saved my bacon many times in the past!
    I was called out to look at this SBS2003 server on friday, stuck on preparing network connections whilst booting. (During the boot, it got stuck on a black screen for 6 minutes before it even flashed the Win2003 logo).
    I rebooted it and tried last known good configuration mode... This time it booted past the network connections screen but got to an Error message....
    LSASS.exe System Error
    And before I got a chance to read the rest of the message it rebooted. Now, no matter which mode I boot up in, (safe, last known good, directory restore) it just brings me back to that message.
    What I did then was cry, and then rebuild the server. That was fine, I dug out the most recent backup tape and cracked on with my restoring, but as soon as I restored the system state data, and rebooted, my problem came back.
    I understand that this is probably due to that LSASS.exe - I expect it's part of the system restore data... is there any way of me restoring AD without that darned file?
    My backup software is (unfortunately) ARCserve.

    Please help. I've got a bag of maltesers on my desk, and it belongs to whoever helps me

    Frustrated of Bournemouth
    Last edited by SolidtechChris; 17th April 2007, 15:10. Reason: Double Signature

  • #2
    Re: SBS 2003. Assistance with System Restore

    I'm not convinced so much that the problem has to do specifically with the file LSASS.EXE itself, but it would be interesting to note what the stock version of LSASS.EXE is in SBS 2003 w/ SP1, veresus the version of LSASS.EXE that is (supposedly) being restored via SystemState restore. In order to accomplish this, you'd need to examine the file version, time/date stamp of LSASS.EXE on a pristine build of SBS 2003 w/ SP1 (or SP2 whatever you're on). If there are discrepancies between the file versions, you might try renaming the suspected faulty version of LSASS.EXE and restoring the pristine version of LSASS.EXE file from a known working server, or perhaps expand it yourself dirctly from the I386 directory of the OS CD or Service Pack files.

    Honestly what I would do right now, if you can, in the interest of time is to re-apply SP1 or SP2 for Win2k3 to see if that resolves the issue.

    A more drastic/exhaustive option which may or may not resolve your problem is to get yourself set up for an ASR recovery of the broken server, and then perform the ASR recovery to see if that resolves your issue. This involves getting a tape backup of the server, creating a floppy diskette which will hold a few files.
    Last edited by jasonboche; 17th April 2007, 15:35.
    VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+ - VMware Virtualization Evangelist
    My advice has no warranties. Follow at your own risk.


    • #3
      Re: SBS 2003. Assistance with System Restore

      Thanks for your reply. The only thing is, I can only restore the whole 'System State'. I can't look at the files within. Plus, if I restore them, i can't boot back up to see if it's worked. If I restore them, and the lsass.exe is knackered, it will go back to being unusable and non-accessible and I'll have to rebuild it again (1hr 20).
      This is why the problem is so frustrating.