Announcement

Collapse
No announcement yet.

DNS auto created A record

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DNS auto created A record

    I have assigned a second IP address to a domain controller, so now in DNS I get 2 entries for the same server name that point to the 2 different IP addresses. Is there a way to prevent this second IP address from getting an A record automatically created for it?

    I have tried manually deleting the A record and it comes back. The 2 IP's are on the same NIC.

    Any help is appreciated.

    Jon

  • #2
    Re: DNS auto created A record

    Not too sure this would work but give it a try:

    Remove the tick from the "Register the connections addresses in DNS" in the "Advanced TCP/IP Settings" dialogue of the network adapter (See image) and then enter the A host record manually.

    Let us know if it works

    Thanks

    Michael
    Attached Files
    Michael Armstrong
    www.m80arm.co.uk
    MCITP: EA, MCTS, MCSE 2003, MCSA 2003: Messaging, CCA, VCP 3.5, 4, 5, VCAP5-DCD, VCAP5-DCA, ITIL, MCP, PGP Certified Technician

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

    Comment


    • #3
      Re: DNS auto created A record

      Thanks for your reply,

      I have tried checking that box to no avail, the A record still gets magically re-created. I am guessing that would probably work on a normal workstation, but since this is a DC it must be doing it another way. Any more ideas are welcome, I am stumped...

      Jon

      Comment


      • #4
        Re: DNS auto created A record

        Originally posted by alaphoid View Post
        Thanks for your reply,

        I have tried checking that box to no avail, the A record still gets magically re-created. I am guessing that would probably work on a normal workstation, but since this is a DC it must be doing it another way. Any more ideas are welcome, I am stumped...

        Jon
        Actually, if that was the culprit, you'd want to UNCHECK the box.

        At any rate, that setting is specific to the NIC interface and since the NIC is the owner of both IP addresses, it's going to control the registration of both IP addresses in DNS namespace.
        VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+
        boche.net - VMware Virtualization Evangelist
        My advice has no warranties. Follow at your own risk.

        Comment


        • #5
          Re: DNS auto created A record

          Ahh yes sorry for my typo, I did uncheck the box Checking/unchecking this box however does not seem to have an effect either way on the DNS registration, I still get both IP addresses registered to the server name.

          Thanks,
          Jon
          Last edited by alaphoid; 16th April 2007, 18:08.

          Comment


          • #6
            Re: DNS auto created A record

            Originally posted by alaphoid View Post
            Ahh yes sorry for my typo, I did uncheck the box Checking/unchecking this box however does not seem to have an effect either way on the DNS registration, I still get both IP addresses registered to the server name.

            Thanks,
            Jon
            Can you be sure it was a new registration? In other words, each time you test, right before you test, are you sure that the previous registration records have been removed from DNS so that you are sure you are starting out with a clean slate each time?

            As far as the check box not having an effect, take a look at the screenshot attachment.
            Attached Files
            VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+
            boche.net - VMware Virtualization Evangelist
            My advice has no warranties. Follow at your own risk.

            Comment


            • #7
              Re: DNS auto created A record

              Is this the only DNS on this domain?
              1 1 was a racehorse.
              2 2 was 1 2.
              1 1 1 1 race 1 day,
              2 2 1 1 2

              Comment


              • #8
                Re: DNS auto created A record

                I had this problem myself.
                I've just fixed it.
                Open the DNS server MMC
                Right click the server
                Properties
                Interfaces
                And choose only the interfaces which you want the DNS server to listen on.

                KB article here:
                http://support.microsoft.com/kb/275554

                Comment


                • #9
                  Re: DNS auto created A record

                  Originally posted by Martin Lee View Post
                  I had this problem myself.
                  I've just fixed it.
                  Open the DNS server MMC
                  Right click the server
                  Properties
                  Interfaces
                  And choose only the interfaces which you want the DNS server to listen on.

                  KB article here:
                  http://support.microsoft.com/kb/275554
                  I'll have to go ahead and disagree on this thought process.

                  The OP said he doesn't want one of the IPs to have a registered ANAME in DNS. The OP did not say it was acceptable to stop DNS from listening all together on an interface. As far as we know, the OP only has one NIC in his DNS server anyway and can't afford to disable it.

                  Also, if you read the KB article you posted, it won't work for the OP anyway:

                  RESOLUTION
                  NOTE: The resolution that is described in this article only works on member servers that run DNS in a domain. It does not resolve this issue on domain controller computers.
                  VCDX3 #34, VCDX4, VCDX5, VCAP4-DCA #14, VCAP4-DCD #35, VCAP5-DCD, VCPx4, vEXPERTx4, MCSEx3, MCSAx2, MCP, CCAx2, A+
                  boche.net - VMware Virtualization Evangelist
                  My advice has no warranties. Follow at your own risk.

                  Comment


                  • #10
                    Re: DNS auto created A record

                    Well, my advice worked for me on two domain controllers, perhaps it's changed since Server 2000 to 2003.
                    Also, I think the "Interfaces" label is a misnomer, the section is used for defining the IP addresses that the DNS server listens on. It would appear the crux of what is going on is that the DC is saying to itself "I'm here" on an IP address, and then registering an A record. If you stop the DC from listening on that IP address then that A record won't be created.

                    I'm still fairly confident my advice will work without any problems.

                    Comment


                    • #11
                      Re: DNS auto created A record

                      Thank you Martin, that suggestion fixed my problem

                      I set the DNS server to only listen on the main IP address, then manually removed the A records that were ponting to the second IP and so far they have not recreated themselves.

                      Thanks again man!

                      Jon

                      Comment

                      Working...
                      X