Announcement

Collapse
No announcement yet.

How to share folder which is viewable to certain users only

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to share folder which is viewable to certain users only

    Hi,

    I am using Windows 2000 server, and would like to create shared folder for each of the users, whereas each user is only accessible to their respective folder, and could not access other user's folder. What is the way to implement this?

    Thanks.

    Best regards,
    TKT

  • #2
    Either share the topmost folder and give everyone FC, and maintain proper per-user NTFS security on the folders, or do the same but use shares that are pointing directly to the users' folders in the format of \\server\share\%username%.
    Cheers,

    Daniel Petri
    Microsoft Most Valuable Professional - Active Directory Directory Services
    MCSA/E, MCTS, MCITP, MCT

    Comment


    • #3
      Hi,

      I tried to give full control to everyone in the permission and removed everyone in the security before adding the user whom I want to share to, but it just didn't work.


      Best regards,
      TKT

      Comment


      • #4
        $ works great

        I use a "$" after the folder name and this "hides" it from browsing on the network. Then I map each user to their folder. After that, I set the permissions on each folder to the respected user.

        Comment


        • #5
          Hi,

          I would appreciate if you could elaborate more on how to set the permission for each user. I give the permission to Everyone and removed Everyone from security before adding that user in. It didn't work that way.

          Best regards,
          TKT

          Comment


          • #6
            Security

            Hello,

            I was out of the office yesterday and wasnt able to get back to you right away. But here is what you need to do...

            Right click on the folder that you want to set permissions. Click on properties, then go to the Security tab. At the bottom of the window that appears, uncheck the "Allow inheritable Properties" box and then click on the copy button on the screen that pops up. This copies a static version of the inheritable properties to the folder. After that, click on the "Add" or "Remove" buttons on the top right of the security box for the users. Word of warning: Add or make sure the Admin account is there before removing ANY users; especially the everyone property!

            Comment


            • #7
              Hi,

              I tried every step as illustrated, but it still didn't work. It seems that the permission to access the shared folder is governed by Everyone. I added the user whom I wanted to share to, and then removed Everyone from Security, and no one can access the shared folder. After I added the Everyone in the Security, then all users can access the shared folder. It still didn't meet the purpose to share to just a user instead of to all. Please assist further.

              Thanks.


              Best regards,
              TKT

              Comment


              • #8
                Did you set the permissions at the bottom of the Dialog box in the secutity tab? This is where you can set Read/Write policies for each user that has access to the folder.

                Comment


                • #9
                  Hi,

                  I added the user in the Permission and removed Everyone, but still couldn't access that folder. It seems that Everyone must be added in Security for users to access the folder, but this means that all users can access to the folder.

                  Please assist further.


                  Best regards,
                  TKT

                  Comment


                  • #10
                    Is this the only AD server on the network? If not, is it the PDC and are you giving AD time to replicate to other servers before trying access? I believe AD partners replicate every 15 minutes. The way I explained file access to you is exactly how it is set up on my system and it works fine. the "Everyone" user has been removed from all of the folders that are user specific. Check out the following link:

                    http://www.gustavus.edu/oncampus/com...ring2k.cfm#on4

                    Comment


                    • #11
                      Hi,

                      This is the only PDC in the network. It just didn't work after I removed Everyone from the Security. I added the user before removing everyone from it. Are the steps correct?

                      Thanks.

                      Best regards,
                      TKT

                      Comment

                      Working...
                      X