No announcement yet.

adprep /domainprep fails

  • Filter
  • Time
  • Show
Clear All
new posts

  • adprep /domainprep fails

    I have a single forest/single Domain with two windows 2000 DC's.
    Ran adprep /forestprep.
    The windows2003update revision attribute was updated to 9 and the schema version to 30 on both DC's.
    One day later I ran adprep /domainprep. Status vas:
    Adprep successfully updated the domain-wide information. This message on the
    screen came almost instantly.
    Now when I look for CN=windows2003updates it's not there.
    In the adprep log I have:
    Adprep was about to call the following LDAP API. ldap_modify_s(). The entry to modify is CN=Windows2003Update,CN=DomainUpdates,CN=System,DC =7t,DC=dk.
    LDAP API ldap_modify_s() finished, return code is 0x0
    When I run winnt32 /checkupgrade only the only thing it states is that I
    should remove the administrative tools.
    I am a little reluctant to go ahead an upgrade the win2K DC to Win2K3 in
    this senario. (netdiag and dcdiag runs with no hickups)
    Does anyone have some advice ?.

  • #2
    Re: adprep /domainprep fails

    Problem solved.

    As it turns out I had been looking in the wrong place for the domain updates container.
    I used ADSIedit to check for the forest and domain updates.
    This afternoon I did: dsa.msc /server=ipaddress. Up popped ACTIVE DIRECTORY USER and COMPUTERS.
    And there it was, under: system\domainupdates\windows2003updates.
    I was kind of lucky ,though, in that I 4 or 5 years ago had enabled advanced features so that I could actually
    see the containers. The operations container has 52 GUID in it. I checked a couple of them.
    Now in order to be really happy I need to locate, in Microsoft’s words:

    If all the operations in the following list succeed, the CN=Windows2003Update object overall task will be stamped
    as completed successfully by setting the revision attribute (CN=Revision in the schema, syntax Integer) to 8.

    Adprep did write that value but I can’t seem find it.

    Kind regards