No announcement yet.

My Documents folder redirecting with GPO

  • Filter
  • Time
  • Show
Clear All
new posts

  • My Documents folder redirecting with GPO

    I am trying to redirect My Documents folder from client computers (for each individual user) to server. (GPOs are in use, Roaming profiles are not)

    So I made a directory named "shared" on d:\ on the server and enabled sharing, leaving it with default settings.

    Next, I opened Active Directory Users and Computers, selected the OU (which contains all of my users and computers) and choose the applied GPO.

    Under Windows Settings, there is a Folder Redirection, which has a folder named My Documents. Under its Properties i used this settings:

    Basic - Redirect everyone´s folder to the same location.

    Target folder location:
    Create a folder for each user under the root path

    Root path:

    But when I log on to the client computer, as a user, the path to My Documents is still pointing to the local machine.

    I would really apprechiate any help on this. Thanks!

  • #2
    Things to check:

    1) Refresh the policy or reboot the computers.

    2) Make sure the GPO has been replicated to all DCs.

    3) See if the user's user account is in the right OU.

    4) Do all other settings that are configured in that GPO apply to the user?

    5) Use GPRESULT to find out if the GPO has indeed been applied to the user.

    6) See event logs.

    Daniel Petri
    Microsoft Most Valuable Professional - Active Directory Directory Services


    • #3
      Thanks for replying, Daniel!

      I checked everything you suggested and it´s OK.

      It looks like that the problem lies in the permissions for the shared folder. Under the Permissions I added, next to Everyone, one user and for that one the redirecting started to work.

      I have 70+ users and they are all in one OU. Should I put them in a new group and add the whole group to the "Permissions" list? I really don´t want to add every single user individualy in it.

      Um... btw, a silly question: where to create new Groups? Should I do it with the Active Directory Users and Computers? And where is the best place to put a group of users who are in a OU (which is in domain root).



      • #4
        1) Make sure that System account has Full Control over the folder (NTFS perms) and the share (share level perms)

        2) If you are on W2K3, the default share permissions are read only. You can either add "Authenticated Users" with Change permissions or create a user group and grant it Change permissions over the share.
        Guy Teverovsky
        "Smith & Wesson - the original point and click interface"


        • #5
          Hello, Guy!

          A big *thank you* for the tips! Now it is working fine I made a new Group (Local domain -> Security), added some Users in it and configured suggested permissions.


          • #6
            Hello pirx,

            In addition to your folder redirection settings, I think these sites will provide more information on it.

            Enabling the Administrators to have access to Redirected Folders

            Folder Redirection FAQs


            • #7
              Hello azmantek,

              this was *exactly* what I was looking for next Thank you!


              • #8
                To pirx,

                Do you have a plan to remove old profiles from XP clients? If not, I suggest you to read this


                • #9
                  Another useful link, thanks, I am sure, this is going to be a very good help for a lot of users here.