Announcement

Collapse
No announcement yet.

dns not functioning properlly

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • dns not functioning properlly

    Hi

    We have DNS sever cofigured on Win 2003 The DNS was working well till last evening. The LAN users uses this DNS server for internet access. Suddenly we face problem with internet access in LAN. Once we restart the DNS services the internet works fine for some period. We need to restart periodically when ever we face this issue. Any idea what could be the Problem? The event log for DNS doesn't have any error.. Pls advise any trouble shooting methord.

    ( DNS forwarding configured for ISP IPs)

    Thanks and Regards

    Prabu
    prabu

  • #2
    Re: dns not functioning properlly

    Are there warnings or error messages in the eventviewer?

    \Rem

    EDIT:
    "The event log for DNS doesn't have any error.. " OEPSS
    (make sure that at the properties of the dns sever at tab Eventlogging 'All Events' is selected)

    You have your server protected against cache pollution at the tab Advanced?
    To check: right-click Suptools.msi in the Support\Tools folder on the Windows Server 2003 CD-ROM, and then click Install.
    After the installation type:
    Dnscmd /Info /SecureResponses
    (more: Dnscmd Overview)

    How many Name Servers do you have on the network, and how are they related?

    \Rem
    Last edited by Rems; 7th February 2007, 21:37.

    This posting is provided "AS IS" with no warranties, and confers no rights.

    __________________

    ** Remember to give credit where credit's due **
    and leave Reputation Points for meaningful posts

    Comment


    • #3
      Re: dns not functioning properlly

      What happens if you remove the forwarders and use the root servers??

      Comment


      • #4
        Re: dns not functioning properlly

        hi REMS ,, there is no error in the eventviewer.. i suspect the error because of DNS is not recognising the requets from the network it is in. When i give nslookup from client PCs i get no reply from server. Once i restart the service, i am able to reach the server. So I think in between the server is loosing its identity of being in the domain.. Any chance of it ??
        prabu

        Comment


        • #5
          Re: dns not functioning properlly

          Hi
          I configured the forwarding only after I started having the issue. So it may no be the issue. When the users are faceing the problem, i am very well able to browse the internet from the server. So i think server is not giving response to the clients requests......
          prabu

          Comment


          • #6
            Re: dns not functioning properlly

            You installed all the Windows Server updates (and servicepack)?

            Try to ping the ipaddress of the server from a client, the time they have no dns. (???). Reboot one of the clients at that time, can they logon now. (???)
            Troubleshooting DNS servers.
            DNS Client Receives Name Not Found Error.

            Although it seems like an internal problem, do try this,
            Test the DNS server to only use forwarders and not attempt any further recursion if the forwarders fail. To do so select the Do not use recursion for this domain check box on the Forwarders tab.


            \Rem
            Last edited by Rems; 8th February 2007, 16:41.

            This posting is provided "AS IS" with no warranties, and confers no rights.

            __________________

            ** Remember to give credit where credit's due **
            and leave Reputation Points for meaningful posts

            Comment


            • #7
              Re: dns not functioning properlly

              IMHO it might have to do with either Dynamic Updates possibly being enabled, or Zone Transfers being improperly configured. It could also be an SOA issue but that would either relate to your Dyamic Updates or refresh intervals.

              Comment


              • #8
                Re: dns not functioning properlly

                Originally posted by ajaxsaur View Post
                IMHO it might have to do with either Dynamic Updates possibly being enabled, or Zone Transfers being improperly configured. It could also be an SOA issue but that would either relate to your Dyamic Updates or refresh intervals.
                Hmm, possibly but I would think that would only affect the local DNS namespace.

                It may be time for wireshark to take a peek at the DNS requests to see what's happening when names don't resolve.

                ssckrp,
                -could you tell us the exact symptoms the client experience? (e.g. opens a web browser, types in website name and gets message "Cannot Display Page"... etc)
                -can client resolve local hosts?
                -use nslookup to query the DNS server to see what response it gives you.

                EDIT - does the DNS server have any other roles? (e.g. DC, DHCP, ISA or RRAS, etc)
                Last edited by JeremyW; 9th February 2007, 15:56.
                Regards,
                Jeremy

                Network Consultant/Engineer
                Baltimore - Washington area and beyond
                www.gma-cpa.com

                Comment

                Working...
                X