Announcement

Collapse
No announcement yet.

Isolate User mode cannot work internally but not externally

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Isolate User mode cannot work internally but not externally

    My company has a PDC (Win Server 2003) and it has set to be the FTP server for our customer to login and get their files according to login name we provided to them. Different username login will get them to different folder.

    Everything is work fine, but recently, it is found that when internally (intranet) access the FTP server through IE browser, it will forward directly to the root FTP folder, but not the assigned folder. But the forwarding works properly for using CuteFTP or FTP command in command prompt, and outside my office network.

    Could anyone give your kindly advice? Is the IIS settings problem or something else?

    My server is Windows Server 2003 which is PDC, with Exchange Server 2003, FTP, IIS6.0 together.

    Thank!

  • #2
    Re: Isolate User mode cannot work internally but not externally

    Internally (intranet) through IE, don't you automatically authenticate as the domain user by default? Would that user be directed to the FTP root?

    Externally or using another tool internally, you need to specify the username and password, correct?

    If you format your URL as follows, you can specify a different username:

    ftp://<username>@<ftpsite>
    ftp://<username>:<password>@<ftpsite>

    ftp://[email protected] (internal) or ftp://[email protected] (external) should ask you for Bob's password -- a little safer if you create a shortcut.

    You are aware FTP usernames and passwords are not encrypted?
    Cheers,

    Rick

    ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

    2006-2099 R Valstar. This post is offered "as is" for discussion purposes only with no express or implied warranty of any kind including, but not limited to, correctness or fitness for use. Nothing herein shall be construed as advice. Attempting any activity based on information in this post is done at your own risk.

    Comment


    • #3
      Re: Isolate User mode cannot work internally but not externally

      Do you by any chance have the option "Allow Anonymous Connections" checked, in the Properties -> Security tab of the FTP site? If so, you should not. This way, IE will have to ask for credentials and then will login to the right user.

      Sorin Solomon


      In order to succeed, your desire for success should be greater than your fear of failure.
      -

      Comment


      • #4
        Re: Isolate User mode cannot work internally but not externally

        After finding my "strong password" for the IUSR account and Allowing Anonymous Connections, I can confirm Sorin is right on.

        You must be allowing anonymous to defeat the logon dialog from IE locally.

        Do remember to clear you IE cache after turning off anonymous.
        Last edited by rvalstar; 23rd January 2007, 10:55. Reason: IE cache
        Cheers,

        Rick

        ** Remember to give credit where credit is due and leave reputation points sigpic where appropriate **

        2006-2099 R Valstar. This post is offered "as is" for discussion purposes only with no express or implied warranty of any kind including, but not limited to, correctness or fitness for use. Nothing herein shall be construed as advice. Attempting any activity based on information in this post is done at your own risk.

        Comment

        Working...
        X