Announcement

Collapse
No announcement yet.

how to enable wallpaper display with RDP?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • how to enable wallpaper display with RDP?

    Hello,

    I am not able to see the wallpaper in a Windows Server 2003 machine when i login as a domain user. This server machine is part of a domain and is acting as one of the client. In Desktop properties, the Background option is disabled. How do i enable this?

    Regards,

  • #2
    Re: how to enable wallpaper display with RDP?

    Sounds like there's a policy preventing you from changing the wallpaper. First thing I would do is run the gpresult command from a command prompt and see what policies are influencing me while logged on. Then I would go and check those GPOs and see which one has the setting that gives me trouble.
    What do you think?

    Sorin Solomon


    In order to succeed, your desire for success should be greater than your fear of failure.
    -

    Comment


    • #3
      Re: how to enable wallpaper display with RDP?

      I haven't set any group policies as of yet on the domain server and even after executing gpresult i don't see any policy that is related to Desktop Background setting. Any other suggestions?

      Comment


      • #4
        Re: how to enable wallpaper display with RDP?

        Originally posted by g_srinivas View Post
        i don't see any policy that is related to Desktop Background setting
        Are there any policies influencing your user? Have you checked what are they set to do?
        Originally posted by g_srinivas View Post
        Any other suggestions?
        Always:
        1) What user are you logging in to? Administrator? Plain user?
        2) Are there any Local Policies set?
        3) Does this server has any particular role, or just member server?
        4) What happens if you log in with another user? Maybe a local one, instead of a domain user?
        TIA.

        Sorin Solomon


        In order to succeed, your desire for success should be greater than your fear of failure.
        -

        Comment


        • #5
          Re: how to enable wallpaper display with RDP?

          No, there aren't any policies influencing the user i am logging in.

          I am logging in as a domain administrator.

          And no there are no local policies defined.

          This is a just a member server, without any specific role.

          The result is the same even when i login as local administrator.

          And by the way, i am logging into the system using Microsoft WinXP RDP with all available options under "Experience" tab.

          Comment


          • #6
            Re: how to enable wallpaper display with RDP?

            Originally posted by g_srinivas View Post
            And by the way, i am logging into the system using Microsoft WinXP RDP with all available options under "Experience" tab.
            Ooooops!
            Looks like I was in the wrong direction here...
            I have missed the RDP thing. It showed only in the subject of the thread, so I forgot it along the way. Now that you mentioned it again...
            I really don't know what to tell you about it, it was always there for me... I never gave it a thought.
            I'll keep searching, maybe I'll find something useful.
            Sorry....

            Sorin Solomon


            In order to succeed, your desire for success should be greater than your fear of failure.
            -

            Comment


            • #7
              Re: how to enable wallpaper display with RDP?

              Hello.
              I think that the answer as follows:
              on the very server's group policy (or alternatively through the domain group policy)
              1: run > gpedit.msc
              2: Computer Configuration
              3: Administrative Templates
              4: Windows Components
              5: Terminal Services
              6: double-click the Enforce Removal of Remote Desktop Wallpaper
              7: Click on Disable
              8: run > gpupdate and it should work
              I did it so myself and it works fine.

              Comment


              • #8
                Re: how to enable wallpaper display with RDP?

                I tried with the Policy setting you suggested, but it doesn't help. The result is still the same. Any more suggestions???

                Comment


                • #9
                  Re: how to enable wallpaper display with RDP?

                  What about the RDP Client? In the advanced settings you can set display options based upon network speed...


                  Tom
                  For my own and your protection, I do not provide support by private message under any circumstances. All such messages will be deleted and ignored.

                  Anything you say will be misquoted and used against you

                  Comment


                  • #10
                    Re: how to enable wallpaper display with RDP?

                    It doesn't look like a client issue. I am using RDP6 client to connect to a 2003 server, with a user that is part of Administrators group.
                    Whenever I login through RDP, cannot change background. I checked that I am using LAN (10MBPs or higher) setting under Experience tab and Highest quality (32bit) under Display tab. And still, no way to change the background.
                    Useless to say that when I login on the servers' console, I can change the background.
                    Looked around a little bit, there's a post on Experts-Exchange, but I'm not one of their customers.
                    Anyone else luckier than me?

                    Sorin Solomon


                    In order to succeed, your desire for success should be greater than your fear of failure.
                    -

                    Comment


                    • #11
                      Re: how to enable wallpaper display with RDP?

                      http://www.experts-exchange.com/Oper..._21637837.html

                      Then, I guess it's not doable. . .

                      You are not "Authorized" to change the Desktop Background while in Remote Desktop, not even in the New " Windows Vista Build 5270 ".

                      Best Regards !
                      1 1 was a racehorse.
                      2 2 was 1 2.
                      1 1 1 1 race 1 day,
                      2 2 1 1 2

                      Comment


                      • #12
                        Re: how to enable wallpaper display with RDP?

                        I am sure there has to be some Local Policy setting that might be disabling the Background tab.

                        The surprising thing is, if i login with any domain user account in main domain server(which as well is running Windows Server 2003), the Desktop Background option is not disabled at all.

                        If the Desktop Background option is disabled for other servers and if this is a common issue with Windows Servers then shouldn't this option be disabled in main domain server as well??

                        And it definitely isn't a RDP client issue at all as i have gone through every available option.

                        Regards,

                        Comment


                        • #13
                          Re: how to enable wallpaper display with RDP?

                          When you log onto the server with any domain account, you are logging on locally/physically to the server aren't you?

                          I have several servers that all have the same problem when using RDP. You can NOT change the wallpaper.

                          I know for fact that there are NO policies on any of the servers that could do this.
                          1 1 was a racehorse.
                          2 2 was 1 2.
                          1 1 1 1 race 1 day,
                          2 2 1 1 2

                          Comment


                          • #14
                            Re: how to enable wallpaper display with RDP?

                            I mean through RDP Client only, when i said "login with any domain user account in main domain server". How would you explain this then??

                            Comment


                            • #15
                              Re: how to enable wallpaper display with RDP?

                              What version of the client are you using?
                              1 1 was a racehorse.
                              2 2 was 1 2.
                              1 1 1 1 race 1 day,
                              2 2 1 1 2

                              Comment

                              Working...
                              X