No announcement yet.

Challenging problem on 2003 server.

  • Filter
  • Time
  • Show
Clear All
new posts

  • Challenging problem on 2003 server.


    I have a .net application that makes use of sql server that has a strange problem, it will only 'fully work' when I set the application pool identity to 'localsystem' OR run the server in IIS5 isolation mode, neither of which I want to do.

    There are two things that have happened with this server that may be clues:-

    a) The server was originally installed as UK region, but now the region is US and I noticed a couple of datetime errors a while back that seemed to be related to the problem.

    b) The server originally had terminal services on it but this has since been removed, I am not sure what applications were installed with TS, is there a way to 'clean up' after removing TS and switching to remote desktop?

    c) If I build a clean IIS6 server on a fresh box and put the application on it then point the connection string to the server I am talking about, everything works perfectly with the app pool running as 'networkservice' so I know it isn't SQL related.

    I have tried reinstalling IIS / but this had no effect.

    When I right click on any folder and check 'security' there is an 'Unknown Account' I am not sure if this is related to me removing TS.

    My problem is this, the server is in a data centre and it is not possible for me to get physical access to it for a rebuild for a couple of months.

    If anyone has an idea of what could be causing the problem or things that I could check I would very much appreciate your thoughts.

    I've tried ALL of the built in identities in the app pool and i've tried creating a custom user with all the IUSR priveliges and more but this did not work either.

    Thank you.