Announcement

Collapse
No announcement yet.

Exchange machine account gone in AD after Domain controller reboot

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange machine account gone in AD after Domain controller reboot

    When I reboot my domain controller that holds the Infrastructure FSMO role, it deletes the machine account in AD for my Exchange Server when the domain controller comes back up. Of course no one then can get any email. The short term fix for this problem is to:

    1. Sign onto the Exchange server locally.
    2. Join a workgroup.
    3. Reboot the Exchange Server.
    4. Sign onto the Exchange server locally.
    5. Re-join the domain.

    Then everything works fine and people send and receive email again until I reboot the domain controller that holds the Infrastructure FSMO role. Consequently the Exchange account gets deleted from AD and I have to go through steps 1-5 again to re-establish my Exchange server onto my domain.

    What is the real fix for this?

    Here is my environment:

    Domain Controllers: 2 - Windows 2000 Servers with SP-4 and all the updates from Microsoft as of a few days ago.

    Exchange Server: Exchange 2000 Enterprise Server with SP-3 running on Windows 2000 Server with SP-4 and all the updates from Microsoft as of a few days ago.

    DC1 holds the Schema and Operations Master roles. This is the only Global Catalog server in the domain.

    DC2 holds the RID, PDC and Infrastructure Master roles.

    I have created temporary (and later dcpromo'ed) DCs where I have transfered the Infrastructure FSMO role. Once again the Exchange account gets deleted from AD and I have to go through steps 1-5 to re-establish my Exchange server onto my domain.

    Thanks in advance for your help,

    Bob Seeds
    Last edited by RSeeds; 4th September 2006, 15:17.
Working...
X