Announcement

Collapse
No announcement yet.

outlook web access will not load up - page constantly loading

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • outlook web access will not load up - page constantly loading

    I have a new install of sbs 2011 - well, its been live for a month or two.

    I was troubleshooting an unrelated issue and I tried to get onto OWA and realized it wont load - it doesn't display any sort of error and it doesn't time out, but it just continuously tries to load the page.

    I know its getting so far as it brings up a certificate warning - as we use a self generated certificate.

    I have tried both remotely and locally from the server itself (using https://localservername/owa) and both have the same result.

    Incidentally, all users have iphones and they connect to exchange activesync without issue.

    Any ideas?
    David Silvester
    Systems Administrator

  • #2
    Re: outlook web access will not load up - page constantly loading

    Update: Yes, after waiting for about 5 minutes, I just realized it does actually time out and gives a page cannot be displayed error.
    David Silvester
    Systems Administrator

    Comment


    • #3
      Re: outlook web access will not load up - page constantly loading

      Hi. First thing I would you is check the exchange EWS virtual directories and make sure the internal and external URLS and URI are correct: I can't post links yet, so search for "set exchange 2010 virtual directories"

      If you are still having issues, then you can reset the virtual directories and reconfigure them: search for:
      "Exchange 2010 reset virtual directories"

      I don't think a self signed cert would cause this, but I have in general found that SBS is a lot happier with a trusted cert.

      Oh and it may be worth running the "connect to the internet" and "fix my network" wizards.

      Good luck!

      Andy cox MCSE server 2012
      Network engineer

      Comment


      • #4
        Re: outlook web access will not load up - page constantly loading

        Do you use a proxy for the internet and perhaps need to exclude local addresses such as OWA.

        Comment


        • #5
          Re: outlook web access will not load up - page constantly loading

          Have you tried the "Fix My Network" wizard?
          TIA

          Steven Teiger [SBS-MVP(2003-2009)]
          http://www.wintra.co.il/
          sigpic
          Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

          We donít stop playing because we grow old, we grow old because we stop playing.

          Comment


          • #6
            Re: outlook web access will not load up - page constantly loading

            Sorry about the late reply guys, I kept avoiding this problem as its confusing me!!

            Andycoxuk
            I have googled that, but not implimented anything yet, I dont fully understand what to do so I need to read up on it, BUT Im not sure if its just exchange/owa (See below).

            Virtual
            No, no proxy server involved.

            teiger
            I havent tried that yet, can I run it remotely, are there any implications, dont want to lock myself out really.

            Some more info:
            its strange, forgetting about OWA for a minute, if I just browse to the root of the server, remotely, at the following URL:
            https://mail.domain.com
            I get the IIS landing page.
            However, the remote access FQDN as per SBS (And as per the SSL cert) is:
            remote.domain.com
            But if I go to that address:
            https://remote.domain.com
            it just loads continuously. -But note that both mail.domain.com and remote.domain.com DO resolve to the correct public IP address.

            ??

            So I guess thats where the problem lies?
            David Silvester
            Systems Administrator

            Comment


            • #7
              Re: outlook web access will not load up - page constantly loading

              it's preferable to run fix-my-network onsite (Or at least, connect to a workstation on the network and use that to RDP in then run it)
              Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

              Comment


              • #8
                Re: outlook web access will not load up - page constantly loading

                Originally posted by tehcamel View Post
                it's preferable to run fix-my-network onsite (Or at least, connect to a workstation on the network and use that to RDP in then run it)
                Thanks, I'll try it tomorrow. I'll go on site - it's only round the corner anyway
                David Silvester
                Systems Administrator

                Comment


                • #9
                  Re: outlook web access will not load up - page constantly loading

                  BTW, the landing page for OWA in SBS 2011 is
                  remote.domain.com/owa
                  TIA

                  Steven Teiger [SBS-MVP(2003-2009)]
                  http://www.wintra.co.il/
                  sigpic
                  Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

                  We donít stop playing because we grow old, we grow old because we stop playing.

                  Comment


                  • #10
                    Re: outlook web access will not load up - page constantly loading

                    Originally posted by teiger View Post
                    BTW, the landing page for OWA in SBS 2011 is
                    remote.domain.com/owa
                    Your on an answering rampage today ay

                    Thanks, I have tried that path and it will not work. And also, I have found when people are trying to set out of office remotely (via Exchange over HTTP) it is also erroring, which I think may be related.

                    I am going to try repairing the connection from SBS console - but going to wait until I can go on site Monday.
                    David Silvester
                    Systems Administrator

                    Comment


                    • #11
                      Re: outlook web access will not load up - page constantly loading

                      I tried SBS fix my network but it didnt find anything major - only that it couldnt configure my router and that I was using forwarders instead of root hints.

                      I checked the application log and found event ID 2307 over and over again:

                      Code:
                      The worker process for application pool 'MSExchangeOWAAppPool' encountered an error 'Cannot read configuration file
                      ' trying to read configuration data from file '\\?\<EMPTY>', line number '0'.  The data field contains the error code.
                      I have goggled this, but cant really understand what the problem is. Maybe some corruption in a system file somewhere.

                      Any ideas?
                      David Silvester
                      Systems Administrator

                      Comment


                      • #12
                        Re: outlook web access will not load up - page constantly loading

                        Have you run the SBS BPA?
                        Exchange BPA?
                        Does RWW work?
                        Regards,
                        Jeremy

                        Network Consultant/Engineer
                        Baltimore - Washington area and beyond
                        www.gma-cpa.com

                        Comment


                        • #13
                          Re: outlook web access will not load up - page constantly loading

                          I recall seeing this exact error, or at least, related to the config file
                          somewhere in the file there's an extra / or \ or something.. stand by


                          here:
                          http://forums.iis.net/t/1170240.aspx

                          see if that helps
                          seems permission-wise

                          i was actually thinking of a slightly differnt error, but hopefully this helps
                          Last edited by tehcamel; 27th February 2014, 11:27.
                          Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

                          Comment


                          • #14
                            Re: outlook web access will not load up - page constantly loading

                            Originally posted by tehcamel View Post
                            I recall seeing this exact error, or at least, related to the config file
                            somewhere in the file there's an extra / or \ or something.. stand by


                            here:
                            http://forums.iis.net/t/1170240.aspx

                            see if that helps
                            seems permission-wise

                            i was actually thinking of a slightly differnt error, but hopefully this helps
                            Thanks, I checked the link, and notably this post:

                            Please check the identity account of 'MSExchangeOWAAppPool' app pool in IIS manager and make sure it has read permission to read applicationHost.config file in system32\inetsrv\config directory. Also it should have read permission on the site's web.config file.

                            I checked in IIS admin, application pools, and MSExchangeOWAAppPool uses localsystem account, which I assume is SYSTEM in the security tab.

                            SYSTEM does indeed have read access to applicationHost.config.
                            David Silvester
                            Systems Administrator

                            Comment


                            • #15
                              Re: outlook web access will not load up - page constantly loading

                              Originally posted by JeremyW View Post
                              Have you run the SBS BPA?
                              Exchange BPA?
                              Does RWW work?
                              I have just installed and ran SBS BPA - in results pane under non-compliant, it shows no entries, so I assume all is ok there.

                              Just trying to install Exchange BPA now, but I am getting an error that Net framework 1.1 is required - I would have thought the server would have a more recent version of framework already installed, is it safe to install that?

                              RWW, what is that?
                              David Silvester
                              Systems Administrator

                              Comment

                              Working...
                              X