Announcement

Collapse
No announcement yet.

sbs2008 mx.google.com rejects email

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • sbs2008 mx.google.com rejects email

    We are a small company with less than 50 employees so I do the IT for the three people in the office and handle the email for the guys in the field.... About ten days ago mx.google.com started rejecting our email and I cannot figure out what the problem is... ISP is comcast, godaddy hosts our domain, we have a static ip address, I turned off ipv6 and email went through to the gmail servers HOWEVER I quickly realized sbs2008 NEEDED ipv6 so I turned it back on and once again email is being rejected from mx.google.com


    This is what I get:



    Your message wasn't delivered because of security policies. Microsoft Exchange will not try to redeliver this message for you. Please provide the following diagnostic text to your system administrator.

    The following organization rejected your message: mx.google.com.



    Sent by Microsoft Exchange Server 2007


    Diagnostic information for administrators:

    Generating server: SERVER.mydomain.local

    [email protected]
    mx.google.com #550-5.7.1 [2002xxxxxxxxxxxxxxxxxxxx 16] The sender does not 550-5.7.1 meet basic ipv6 sending guidelines of authentication and rdns 550-5.7.1 resolution of sending ip. Please review 550 5.7.1support.google.com/mail/answer/81126 for more information. f43si6791143yhc.407 - gsmtp ##


    Original message headers:
    Last edited by Jerz; 27th August 2013, 13:58.

  • #2
    Re: sbs2008 mx.google.com rejects email

    Have you reviewed the document from Google?

    https://support.google.com/mail/answer/81126

    Comment


    • #3
      Re: sbs2008 mx.google.com rejects email

      I fixed it!!! Yes I reviewed the google document but it is pretty worthless when you have everything setup correctly... The problem was the ipv6 headers were going through (apparently ,unlike any other server, google looks for ipv6 first instead of ipv4) so I had to change a setting in my Netgear WNDR4500 to DISABLE IPV6.... By default this router has the WAN IPV6 setting set to "Auto Detect"; I changed it to "Disabled" and all is well.

      I guess either Comcast turned on IPV6 10 days ago OR google changed its' security policy... either way... I hope this helps other and DO NOT TURN OFF IPV6 ON AN SBS2008 BOX! ESPECIALLY with the Microsoft script... you will regret it.

      Comment


      • #4
        Re: sbs2008 mx.google.com rejects email

        Originally posted by Jerz View Post
        I fixed it!!! Yes I reviewed the google document but it is pretty worthless when you have everything setup correctly... The problem was the ipv6 headers were going through (apparently ,unlike any other server, google looks for ipv6 first instead of ipv4) so I had to change a setting in my Netgear WNDR4500 to DISABLE IPV6.... By default this router has the WAN IPV6 setting set to "Auto Detect"; I changed it to "Disabled" and all is well.

        I guess either Comcast turned on IPV6 10 days ago OR google changed its' security policy... either way... I hope this helps other and DO NOT TURN OFF IPV6 ON AN SBS2008 BOX! ESPECIALLY with the Microsoft script... you will regret it.
        Excellent news.

        Thanks for posting back with your findings. You never quite know when someone else will experience an issue like this.

        Comment


        • #5
          Re: sbs2008 mx.google.com rejects email

          This is not a fix, it's a workaround. Same with disabling ivp6 on the server (not a fix, it's a workaround). Another workaround is dumping onsite Exchange and moving to a hosted solution, or leaving Microsoft altogether and signing up for Google's mail service (I'm sure this would be Google's recommendation).

          Comment


          • #6
            Re: sbs2008 mx.google.com rejects email

            Originally posted by Jerz View Post
            I fixed it!!! Yes I reviewed the google document but it is pretty worthless when you have everything setup correctly... The problem was the ipv6 headers were going through (apparently ,unlike any other server, google looks for ipv6 first instead of ipv4)
            That's not what happened. Whether or not IPv6 is being used for connecting to a mail server (or any other server) is up to the client. Since both your mail server and your router had IPv6 connectivity, Exchange decided to use IPv6. And since there's something wrong with your IPv6 setup (like missing RDNS or no IPv6 address in the SPF record), the mail got rejected.

            I'd have to agree with HotSpotComputing that your fix is really just a workaround, and not a very good one.

            Comment

            Working...
            X