Announcement

Collapse
No announcement yet.

SBS 2003 -> 2011 Migration issues.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SBS 2003 -> 2011 Migration issues.

    I'm having some problems with running the SBS 2011 migration tool on an SBS 2003 Pemium R2 server.
    First off, the "Update the schema" part has a cross by it.
    Secondly, the Baseline Configuration Analyser comes up with a '"Log on as a batch job" user right assignment is not correct' error.
    However, on checking (Rule 8 from kb2578426)...
    <<
    Rule 8
    This update adds the following rule to check whether the "Log on as a batch job" user right in the Default Domain Controllers GPO applies to the Administrators group on the migration source server:
    Rule: "Log on as a batch job" user right assignment is not correct
    Severity: Error
    Description: The Default Domain Controller group policy setting "Log on as a batch job" should include BUILTIN\Administrators. Go to kb2578426 for more information.
    Actions to take if this rule is violated
    To resolve this rule violation, edit the Default Domain Controllers GPO. To do this, follow these steps:
    Start the Group Policy Management Console (Gpmc.msc).
    Expand the Group Policy Objects container.
    Right-click Default Domain Controllers Policy, and then click Edit.
    Expand Computer Configuration, expand Windows Settings, expand Security Settings, expand Local Policies, and then expand User Right Assignment.
    Under User Rights Assignment, locate and double-click Log on as a batch job.
    Make sure that the Define these policy settings check box is selected.
    Click Add User or Group and make sure that the following groups are in the list:
    Administrators
    PerformanceLogUser

    If any of these groups are not in the list, add them by clicking Add User or Groupů. Then, click OK.
    Refresh Group Policy on the server. To do this, open a command prompt, type the following command, and then press Enter:
    gpupdate /force
    >>
    ...I find that administrators is already on the list.
    SourceTool.log...
    07/01/2013 19:26:03 Starting task Raise the functional level of the domain and forest
    07/01/2013 19:26:03 Starting Task: Raising domain and forrest functional level.
    07/01/2013 19:26:03 Domain name is: DC=bacs-net,DC=local
    07/01/2013 19:26:03 current domain functional level is: 2
    07/01/2013 19:26:03 No need to change.
    07/01/2013 19:26:03 current forrest functional level is: 2
    07/01/2013 19:26:03 No need to change.
    07/01/2013 19:26:03 Task finished successfully
    07/01/2013 19:26:03 Starting task Update the schema
    07/01/2013 19:26:03 adprep.exe Exists: False
    07/01/2013 19:26:03 adprep\adprep.exe Exists: True
    07/01/2013 19:26:03 Running C:\Program Files\Windows Small Business Server 2011 Standard Migration Preparation Tool\adprep\adprep32.exe /forestPrep /wssg /silent
    07/01/2013 19:26:04
    07/01/2013 19:26:04 Adprep returned: ForestUpdateAlreadyDone(13)
    07/01/2013 19:26:04 adprep.exe Exists: False
    07/01/2013 19:26:04 adprep\adprep.exe Exists: True
    07/01/2013 19:26:04 Running C:\Program Files\Windows Small Business Server 2011 Standard Migration Preparation Tool\adprep\adprep32.exe /domainPrep /gpprep /wssg /silent
    07/01/2013 19:26:04
    07/01/2013 19:26:04
    07/01/2013 19:26:04 Adprep returned: UnableToModifyError(6)
    07/01/2013 19:26:04 Task Finished with Error
    07/01/2013 19:26:04 Starting task Provide licensing support
    07/01/2013 19:26:04 Current version: 5.2.3790.131072
    07/01/2013 19:26:04 Service pack version = 2
    07/01/2013 19:26:05 Running C:\Program Files\Windows Small Business Server 2011 Standard Migration Preparation Tool\KB943494\WindowsServer2003-KB943494-x86-ENU.exe /quiet /norestart
    07/01/2013 19:26:55 Package returned: 3010 (0xBC2)
    07/01/2013 19:26:55 Task finished successfully
    07/01/2013 19:26:55 Starting task Configure Exchange to support migration
    07/01/2013 19:26:55 Changing Exchange to be native mode.
    07/01/2013 19:26:55 Begin adding Authenticated Users to Pre Windows 20008 Compatible Access group
    07/01/2013 19:27:01 AU: LDAP:// bacs-net.local / CN=S-1-5-11,CN=ForeignSecurityPrincipals,DC=bacs-net,DC=local
    07/01/2013 19:27:01 PreWin2k: LDAP:// bacs-net.local / CN=Pre-Windows 2000 Compatible Access,CN=Builtin,DC=bacs-net,DC=local
    07/01/2013 19:27:01 AU is already a member, no-op
    07/01/2013 19:27:02 auSuccess=True, exchangeSuccess=True
    07/01/2013 19:27:02 Task finished successfully
    07/01/2013 19:27:30 Starting health scan using MBCA engine..
    07/01/2013 19:27:32 Health scan: MBCA model has been imported.
    07/01/2013 19:27:32 Health scan: SBSMigrationPrep model is in the mbca model list.
    07/01/2013 19:27:32 Health scan: Invoking SBSMigrationPrep model at 07/01/2013 19:27:32
    07/01/2013 19:27:44 Health scan: invoke result: True
    07/01/2013 19:27:44 Health scan: scan end time: 07/01/2013 19:27:44, duration: 00:00:11.5468750
    07/01/2013 19:27:44 Health scan: 1 issues found.
    07/01/2013 19:27:44 1: id=1, title="Log on as a batch job" user right assignment is not correct, description=The Default Domain Controller group policy setting "Log on as a batch job" should include BUILTIN\Administrators. Go to kb2578426 for more information., severity=Error
    07/01/2013 19:27:44 1 error(s) and 0 warning(s) found during BPA scan
    Any ideas on how to clear these issues?

  • #2
    Re: SBS 2003 -&gt; 2011 Migration issues.

    remove and re-add the administrator from the gpo as identified in the article
    re-force GPUpdate on the server

    double check you have "builtin\administrator" not "domain\administrator" or "administrator" - these are all different.. select it from the list rather than typing it
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: SBS 2003 -&gt; 2011 Migration issues.

      Thanks for that.

      Just so we're on the same page, we're talking about the 'administrators' (with an 's') group here, not the administrator account.

      There's only one on my machine and that's domain.local/builtin/administrators.

      And removing is and re-adding it to the gpo (as per rule makes no difference.

      BTW, I've managed to clear the "update the schema" cross. Apparently I didn't have a registry entry to set my SysVol path (http :// technet.microsoft.com /en-us/library/cc756961(WS.10).aspx)

      so it's just this "Log on as batch job" thing to clear up...

      I also have recurring UserEnv 1006 (Windows cannot bind to mydomain.local domain) and 1030 (Windows cannot query for the list of Group Policy) errors in my eventlog. These errors have been present for a while now and whilst they've never been affecting things before it is possible that they are here. Are they suggesting that gpupdate may not actually be updating anything. Is there a way to check?

      Comment


      • #4
        Re: SBS 2003 -&gt; 2011 Migration issues.

        sounds like your DNS is setup incorrectly if you're getting unable t o to bind to domain
        double check all those settings
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment

        Working...
        X