Announcement

Collapse
No announcement yet.

Can't connect computer to SBS 2008 - 7 hours headache :(

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't connect computer to SBS 2008 - 7 hours headache :(

    Hi everyone,

    I know this issue is addressed over and over on many forums, but I've spent the day going through the threads and couldn't find an answer. I'll try to be clear:

    My problem: I want to connect client computers to my newly installed SBS 2008 and they just won't connect. There is not error, they just don't talk to each other - I suspect a DNS setting problem.

    The context: I just installed SBS 2008 on a machine where SBS 2003 was running before. I did a fresh install and didn't try to migrate anything. There was a domain in place before, with an AD managing it in SBS 2003. Now that 2003 is NOT running anymore, I can STILL connect to the domain with the different logins (to my surprise).
    3 clients run Windows 7
    1 client runs Windows XP
    All computers (server and clients) are connected to a switch via wire, the switch is connected to a DSL router.

    Details on the situation: I suspect there is a DNS problem. When I try to connect to "http : // connect/" from a client, I get a typical "404" error.
    DHCP: the router was running the DHCP server (worked fine with SBS 2003). I turned it off and activated it in 2008, as it was recommended everywhere. But I don't see a change (see logs of a client below)
    DNS: - I used the 2008 IP address as DNS server for a client computer, but it doesn't work. After I make that change, I can't go on Internet anymore.
    - However, I can ping the server, and I can also ping outside addresses like ATT's dns servers.
    - I did change the DNS suffix in the Advanced DNS options of the Internet properties.

    Here are the ipconfig /all logs for the SERVER:

    Code:
    Windows IP Configuration
    
       Host Name . . . . . . . . . . . . : SERVER
       Primary Dns Suffix  . . . . . . . : mycompany.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : mycompany.local
    
    Ethernet adapter Local Area Connection 2:
    
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet #2
       Physical Address. . . . . . . . . : 00-22-19-BE-2F-33
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::5089:8f88:7081:74cd%11(Preferred) 
       Link-local IPv6 Address . . . . . : fe80::a4ac:591f:feaf:381e%11(Preferred) 
       IPv4 Address. . . . . . . . . . . : 192.168.1.2(Preferred) 
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.1.254
       DHCPv6 IAID . . . . . . . . . . . : 285221401
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-C2-97-92-00-22-19-BE-2F-32
       DNS Servers . . . . . . . . . . . : ::1
                                           127.0.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled
    
    Ethernet adapter Local Area Connection:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
       Physical Address. . . . . . . . . : 00-22-19-BE-2F-32
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
    
    Tunnel adapter Local Area Connection* 8:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : isatap.{5B3E31E9-A735-43CD-A5BD-D522A9FFD6BB}
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    
    Tunnel adapter Local Area Connection* 9:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : isatap.{044D3B06-11B4-43AB-BCF5-3425C0AF6E8F}
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    Here are the ipconfig /all logs for a CLIENT COMPUTER:


    Code:
    Windows IP Configuration
    
       Host Name . . . . . . . . . . . . : MYCOMPANY-3
       Primary Dns Suffix  . . . . . . . : MycompanysOldDomain.loc
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : mycompany.local
    
    Ethernet adapter Local Area Connection:
    
       Connection-specific DNS Suffix  . : att.net
       Description . . . . . . . . . . . : Intel(R) PRO/100 VE Network Connection
       Physical Address. . . . . . . . . : 00-12-3F-BB-01-77
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::5c4f:e3ac:136e:911d%10(Preferred) 
       IPv4 Address. . . . . . . . . . . : 192.168.1.112(Preferred) 
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Tuesday, August 02, 2011 4:49:11 PM
       Lease Expires . . . . . . . . . . : Sunday, August 14, 2011 6:07:23 PM
       Default Gateway . . . . . . . . . : 192.168.1.254
       DHCP Server . . . . . . . . . . . : 192.168.1.254
       DHCPv6 IAID . . . . . . . . . . . : 234885695
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-13-BC-39-94-00-12-3F-BB-01-77
       DNS Servers . . . . . . . . . . . : 192.168.1.2
       NetBIOS over Tcpip. . . . . . . . : Enabled
    
    Tunnel adapter isatap.att.net:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : att.net
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    
    Tunnel adapter Local Area Connection* 11:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . : 
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
    I would really appreciate any help that anybody would have... tips, advice... this is making me crazy thanks!
    Last edited by nomade0; 4th August 2011, 20:49. Reason: Sovled - update title

  • #2
    Re: Can't connect computer to SBS 2008 - 7 hours headache

    Run the connect to the internet wizard *again* on the SBS 2008 server.

    Take one of the workstations that was joined to MycompanysOldDomain.loc and join it to WORKGROUP first and reboot. Then try to join it to the SBS 2008 server.
    Network Engineers do IT under the desk

    Comment


    • #3
      Re: Can't connect computer to SBS 2008 - 7 hours headache

      The problem is most likely with the DNS suffix on the clients. You have a connection specific DNS suffix of att.net (which shouldn't be in use at all on an internal AD domain). Get rid of the att.net connection specific DNS suffix and add a mycompany.local connection specific DNS suffix. Also get rid of the mycompany.local DNS suffix search list so that only the connection specific DNS suffix of mycompany.local exists.

      A network capture from the client should confirm what DNS suffix is being appended to it's query for "connect".

      Comment


      • #4
        Re: Can't connect computer to SBS 2008 - 7 hours headache

        It is still using the router/gateway as the DHCP. You should correct that first.
        Also, is the client still a member of the old 2003 domain? If so, remove it.
        TIA

        Steven Teiger [SBS-MVP(2003-2009)]
        http://www.wintra.co.il/
        sigpic
        Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

        We donít stop playing because we grow old, we grow old because we stop playing.

        Comment


        • #5
          Re: Can't connect computer to SBS 2008 - 7 hours headache

          Thank you for your answers! My problem is solved, I thought I had posted my answer.. anyway, here it is again:

          It's finally working! Thanks a lot for your advice that put me on the right track.

          The answer to my problem was to configure as follow:
          • On the client computer, I got rid of the "connection specific DNS suffix" that was bypassing the server and going to ATT.NET. I didn't find a way to just remove the connection-specific DNS suffix, but I modified it to the same as the primary DNS suffix by entering "mycompany.local" on the DNS tab in the Advanced TCP/IP Settings dialog box. More info how to: http://support.microsoft.com/kb/305553
          • At his point, I still couldn't join the domain, BUT I could see the network was identified as mycompany.local.
          • I disabled the DHCP server on the router and enabled it on SBS 2008. To do that, I ran the Internet Wizard on the server. It detected that DCHP was ran by the router, and told me to turn it off. I did. The wizard then turned DHCP on on the server.
          • Hurray! I was then able to join the domain. The automatic "connect" didn't work for whatever reason, but I could join the domain manually.


          Thanks a lot again!!

          Comment

          Working...
          X