Announcement

Collapse
No announcement yet.

Trying to do an Exmerge brick-level backup

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying to do an Exmerge brick-level backup

    I am trying to do a brick-level backup of the mailstore on an SBS 2003 server. Many of the owners / principles are 'administrators'. I elected to create a new account called ExmergeUser specifically for using Exmerge but it fails.

    I get the error: Error encountered getting mailbox information from the private information store database(s) on server 'myserver'. Make sure you have adequate permissions on the information store object.

    I checked the exmerge.log and found this:

    Found 36 mailbox(es) homed on database 'FIRST STORAGE GROUP/MAILBOX STORE (SENSORSRV)'.
    [13:21:21] Ignored 3 mailbox(es) homed on database 'FIRST STORAGE GROUP/MAILBOX STORE (SENSORSRV)'.
    [13:21:21] Found 36 mailbox(es) homed on the specified databases.
    [13:21:21] Ignored 3 mailbox(es) homed on the specified databases.
    [13:21:21] Error initializing MAPI. (CAdminProfileRoutines::CreateSystemAttendantProfi le)
    [13:21:21] Error initializing MAPI.
    [13:21:21] Error initializing MAPI.
    [13:21:21] MAPI has not been initialized (CMapiSession:eleteOurProfile)
    [13:21:21] Error encountered getting mailbox information from the private information store database(s) on server 'SENSORSRV'. Make sure you have adequate permissions on the Information Store object. Please refer to the 'ExMerge.log' log file for more information.

    I am puzzeled about MAPI?

    Here are the settings for user ExmergeUser:
    -member of domain users, server operators, exchange domain servers
    -delegated control, Exchange Full Administrator
    -mailserver object, full control including sendas, receive as, no 'deny' in checkboxes
    -mailbox store, full control including sendas, receive as, no 'deny' in checkboxes

    Intitiated Exmerge by right-click and 'Log on as DOMAIN\ExmergeUser

    I can't see where I have missed anything. Normally I would do this with the administrator account and remove all the 'deny' settings. Because this is not really my netowrk and so many people have 'administrator' rights, I chose an exclusive user to run Exmerge. Any feedback appreciated.

    The log seems to indicate I can access the mailstore. It appears to be failing on MAPI. I am not aware that the customer is using MAPI for anything. How could I confirm this?

    Thanks.
    Network Engineers do IT under the desk

  • #2
    Re: Trying to do an Exmerge brick-level backup

    Kind of stumbled across the solution. The exmerge account I created did not have permission to create the c:\exmerge folder
    Network Engineers do IT under the desk

    Comment

    Working...
    X