No announcement yet.

SBS 2008 RPC failures

  • Filter
  • Time
  • Show
Clear All
new posts

  • SBS 2008 RPC failures

    Hi all
    I'm having a problem with RPC, it started with an error joining a machine to the domain "no more endpoints available from the endpoint mapper"
    - I've logged into the server and can not open the DNS console (although DNS queries appear to work)
    - I've looked into server manager, every service depending on RPC has errors. Acrive directory tells me it cannot connect to the global catalog
    - I've researched the issue and tried the following. reboot server. remove client for microsoft networks - reboot - re-add client for MS networks
    NOTE: in the properties of client for MS networks the name service provider drop down contains both Windows locator and DCE cell directory service. none shows as selected even after selecting one (focusing on windows naming service
    Unfortunately this is a production server with no spare of failover so I need to resolve the issue quickly.
    continuing to google it, any help appreciated!
    dcdiag result below:

    Directory Server Diagnosis

    Performing initial setup:
    Trying to find home server...
    Home Server = QPS-SVR1
    [QPS-SVR1] Directory Binding Error 1753:
    Win32 Error 1753
    This may limit some of the tests that can be performed.
    * Identified AD Forest.
    Done gathering initial info.

    Doing initial required tests

    Testing server: Default-First-Site-Name\QPS-SVR1
    Starting test: Connectivity
    [QPS-SVR1] DsBindWithSpnEx() failed with error 1753,
    Win32 Error 1753.
    ......................... QPS-SVR1 failed test Connectivity

    Doing primary tests

    Testing server: Default-First-Site-Name\QPS-SVR1
    Skipping all tests, because server QPS-SVR1 is not responding to
    directory service requests.

    Running partition tests on : ForestDnsZones
    Starting test: CheckSDRefDom
    ......................... ForestDnsZones passed test CheckSDRefDom
    Starting test: CrossRefValidation
    ......................... ForestDnsZones passed test

    Running partition tests on : DomainDnsZones
    Starting test: CheckSDRefDom
    ......................... DomainDnsZones passed test CheckSDRefDom
    Starting test: CrossRefValidation
    ......................... DomainDnsZones passed test

    Running partition tests on : Schema
    Starting test: CheckSDRefDom
    ......................... Schema passed test CheckSDRefDom
    Starting test: CrossRefValidation
    ......................... Schema passed test CrossRefValidation

    Running partition tests on : Configuration
    Starting test: CheckSDRefDom
    ......................... Configuration passed test CheckSDRefDom
    Starting test: CrossRefValidation
    ......................... Configuration passed test CrossRefValidation

    Running partition tests on : qps-lan
    Starting test: CheckSDRefDom
    ......................... qps-lan passed test CheckSDRefDom
    Starting test: CrossRefValidation
    ......................... qps-lan passed test CrossRefValidation

    Running enterprise tests on : qps-lan.local
    Starting test: LocatorCheck
    ......................... qps-lan.local passed test LocatorCheck
    Starting test: Intersite
    ......................... qps-lan.local passed test Intersite

  • #2
    Re: SBS 2008 RPC failures

    Hi Raj
    Thank you for the detailed information, in my case it has not helped me out, since postng I have come across a few other solutions which have raised more issues.
    I cannot edit objects in group policy. I'm told I don't have permissions and that the network location could not be found
    the account I'm using is a network administrator account in sbs console.
    I've ran MSBPA and it tells me about a lot of dns issues but I cant get to DNS to troubleshoot them. I'm still stuck getting RPC to work


    • #3
      Re: SBS 2008 RPC failures

      The Pheasant: Are you doing a migration -- I thought from your original post it was joining machines to a domain?
      What OS is being joined?
      WHat account is being used? (users can join 10 machines only)
      Tom Jones
      MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
      PhD, MSc, FIAP, MIITT
      IT Trainer / Consultant
      Ossian Ltd

      ** Remember to give credit where credit is due and leave reputation points where appropriate **


      • #4
        Re: SBS 2008 RPC failures

        Hi Ossian
        Your right, there's no migration involved.
        The joining machine is windows 7 Pro (fully patched clean install)
        I have tried to join with the users account (only for troubleshooting) otherwise I'm using the network administrators account
        I'm cornered to troubleshooting RPC, all help seems to point to

        which seems to be more pertinent to server 2003 but I'm trying to work through that anyway.
        in addition to being unable to a computer to the domain I tried to create a new administrator account - ok until I added it to the remote users allowed list in computer properties. again a endpoint mapper not available.
        Thanks again!


        • #5
          Re: SBS 2008 RPC failures

          Unless you can prove and confirm that this blog belongs to you, please refrain from Copy&Paste, or if you do so please make sure that you have a reference from where you got that info from.

          Originally posted by Raj_trust
          Before I tell you how to fix this, if you are ever going to do a migration, I highly recommend you find your way to Jeff Middletonís site SBSMigration and order his book. Even if you are going to do the Microsoft migration every time, you can still learn most about how migrations work and whatís going on from his book than you will anywhere else. It is a great resource to have and reading through it will provide you with a lot of good troubleshooting ideas and places to start when it goes wrong.
          This one happens sometimes. You will install, the AnswerFile gets picked up, and after a few reboots you get a message stating that the AD replication is taking longer than normal, do you want to wait for replication? You have two problems now. First, the Source isnít replicating properly and you need to fix that problem, and secondly, many times the Destination server has stopped trying to replicate because of the failure.
          Source server:
          Check that these services are running, this is the most common cause of failure to replicate:
          Computer Browser
          File Replication Service
          Remote Procedure Call (RPC) (and I always start the Locator too, donít know if it helps but I do)
          Disable Firewall! If you donít make a habit of doing so already, the Firewall can really muck up a migration. You probably have a better firewall in your AV program already anyway. So now you have the problem figured out, letís get the two to start talking again. There is one registry key on the Source, and two on the Destination which need to be fixed.
          HK_LM\System\CurrentControlSet\Services\NTFrs\Para meters\Backup/Restore\Process at Startup
          Change the BurFlags key to D4 on the old server
          Obviously there is no run, so you need to bring up either Task Manager or a command prompt. I know there is another hotkey for CMD but I donít remember what it is most of the time, so I just use CTRL+SHIFT+ESC, which brings up Task Manager. File>New Task will get you a run so you can open up the registry. Now change the same BurFlags key to D2 on the new server and also go find the key HK_LM\System\CurrentControlSet\Services\Netlogon\P arameters and make sure the SysvolReady key says 1, if not change it. Now stop the NTFrs service on both servers, and start the Source first, then the Destination, and on the Destination server click Yes to wait for the AD replication. If it worked, you should see almost immediate results.
          AnswerFile not found:
          When you are installing SBS 2008 in Migration mode you have to use the AnswerFile. You simply cannot do a migration without it. The recommendation from Microsoft is that you put it in the root of a USB key, without changing the name, and the installation will automatically see the key and read the file. They have found several people, however, who cannot see the USB key. The simply fix is that when you install from the DVD, it will put all the files on the C: and reboot. When it does the reboot, before it actually boots from the hard drive, boot to your favorite DOS/PXE and copy the AnswerFile to the C of the server. Then when it restarts and loads from the drive it will recognize the AnswerFile.
          Failed to transfer remaining floating role to DESTINATION:
          This happens when your DNS on Source isnít pointed to Destination. When it happens, usually all that you need to do is repoint the DNS and run DCPROMO again.
          Caesar's cipher - 3


          SFX JNRS FC U6 MNGR


          • #6
            Re: SBS 2008 RPC failures

            Raj_trust's post temporarily deleted until he can confim he has permission to repost the information without requiring a link to the original article.
            Joined: 23rd December 2003
            Departed: 23rd December 2015