Announcement

Collapse
No announcement yet.

Remote Desktop Gateway internal hostname & certificate

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Remote Desktop Gateway internal hostname & certificate

    I have imported and set 3rd party issued certificate for RWW using SBS wizard. Regarding web services everything works fine (OWA, etc.)

    But when I want to connect remotely, through internet, using Remote Desktop client I am offered self-issued certificated for internal domain name "name.domain.local".

    I have installed "Remote Desktop Gateway manager" but I have found somewhere that it should not be used for setting certificate in SBS 2011...

    Thank you for help

  • #2
    Re: Remote Desktop Gateway internal hostname & certificate

    I have the same problem
    all problem is with the certificates
    also when I start outlook 2010 it asking for a premission shown here
    Click image for larger version

Name:	problem.jpg
Views:	1
Size:	47.5 KB
ID:	464833

    Comment


    • #3
      Re: Remote Desktop Gateway internal hostname & certificate

      It is written there for you. It tells you the name on the certificate is not the name of the site (externally) - it is .local - the internal name.
      TIA

      Steven Teiger [SBS-MVP(2003-2009)]
      http://www.wintra.co.il/
      sigpic
      Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

      We donít stop playing because we grow old, we grow old because we stop playing.

      Comment


      • #4
        Re: Remote Desktop Gateway internal hostname & certificate

        So how do I fix it

        Comment


        • #5
          Re: Remote Desktop Gateway internal hostname & certificate

          I have the same issue. Any resolution?

          Comment


          • #6
            Re: Remote Desktop Gateway internal hostname & certificate

            If I a have read this right you sare saying that your new public cert works PERFECTLY fine with OWA and other websites?

            If so then all you need to do is go to Admin tools > Terminal Services > Terminal Services Configuration.
            Double click the RDP-TCP connection under "connections".
            At the bottom click the "Select" button and now choose your new certificate.

            The reason you experience this is because when you set up the new cert using the wizard it ammends the IIS configuration which is responsible for your websites (which OWA is) but it does not ammend the TS settings. I presume this straight RDP and not using a TS gateway? If so then this will work. If a TS gateway it is slighly different, let me know.

            Comment


            • #7
              Re: Remote Desktop Gateway internal hostname & certificate

              I appreciate the response.

              I'm choosing to connect to a PC from RWW, so I think that is RDS (TS). I have followed the instructions for installing the RDS Connection manager and have selected the certificate in there, but it still doesn't use it.

              This is really frustrating...

              Comment


              • #8
                Re: Remote Desktop Gateway internal hostname & certificate

                Yes it probably is.
                Out of interest did you notice the certs were different when you followed my instructions?

                For the gateway do the following:
                Admin tools > Terminal Services > TS Gateway manager

                This must be done on the TS gateway btw...

                In the console that loads right click the server name and choose properties.
                Select the SSL tab.
                At the bottom choose "Browse Certificates" and select your new cert.
                Ok all the boxes.
                You may need to restart all the RDP services for it to take affect.

                Let me know your outcome.

                Comment


                • #9
                  Re: Remote Desktop Gateway internal hostname & certificate

                  Yes, I've done that.

                  BTW, since this is SBS 2011, I am in the RD Gateway Manager. The SSL tab shows my goDaddy cert as installed and in use.

                  I have restarted the server.

                  Comment


                  • #10
                    Re: Remote Desktop Gateway internal hostname & certificate

                    Oh right. Well i have a lot of experience with SBS 2008 but none of 2011 yet. they are more or less the same though. Does 2011 come with TMG? because it may be there where you need to change it instead.

                    Comment


                    • #11
                      Re: Remote Desktop Gateway internal hostname & certificate

                      TMG is NOT included in SBS2011.
                      BTW TMG is now almost officially dead (in support mode).
                      TIA

                      Steven Teiger [SBS-MVP(2003-2009)]
                      http://www.wintra.co.il/
                      sigpic
                      Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

                      We donít stop playing because we grow old, we grow old because we stop playing.

                      Comment

                      Working...
                      X