Announcement

Collapse
No announcement yet.

SBS2011 VSS warning 8230 spsearch error. No backup!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SBS2011 VSS warning 8230 spsearch error. No backup!

    I have update a working version of SBS 2011 with all updates and SP1. Now i have the following, the backup is not running for a few days. In the event viewer i have a large amount of VSS errors.

    Volume Shadow Copy Service error: Failed resolving account spsearch with status 1376. Check connection to domain controller and VssAccessControl registry key.
    Operation:
    Initializing Writer
    Context:
    Writer Class Id: {4dc3bdd4-ab48-4d07-adb0-3bee2926fd7f}
    Writer Name: Shadow Copy Optimization Writer
    Error-specific details:
    Error: NetLocalGroupGetMemebers(spsearch), 0x80070560, The specified local group does not exist.

    _________________________

    Volume Shadow Copy Service error: Failed resolving account spsearch with status 1376. Check connection to domain controller and VssAccessControl registry key.
    Operation:
    Initializing Writer
    Context:
    Writer Class Id: {be000cbe-11fe-4426-9c58-531aa6355fc4}
    Writer Name: ASR Writer
    Error-specific details:
    Error: NetLocalGroupGetMemebers(spsearch), 0x80070560, The specified local group does not exist.

    __________________________

    Volume Shadow Copy Service error: Failed resolving account spsearch with status 1376. Check connection to domain controller and VssAccessControl registry key.
    Operation:
    Initializing Writer
    Context:
    Writer Class Id: {afbab4a2-367d-4d15-a586-71dbb18f8485}
    Writer Name: Registry Writer
    Error-specific details:
    Error: NetLocalGroupGetMemebers(spsearch), 0x80070560, The specified local group does not exist.

    __________________________

    Do you have the same problems???

  • #2
    Re: SBS2011 VSS warning 8230 spsearch error. No backup!

    Is the account 'spsearch' a domain admin account? I needs to be local admin or member of backup operators group on the system.

    Comment


    • #3
      Re: SBS2011 VSS warning 8230 spsearch error. No backup!

      I never made the account "spsearch", MS put it there.

      I checked it and it was not, only member of the "Domain Users" and "WSS-WPG". Added it to the "Backup Operators".

      After changing this still no luck with the backup.

      I also have troubles with user "spfarm".
      Last edited by jantje.vlaam; 12th April 2011, 20:10.

      Comment


      • #4
        Re: SBS2011 VSS warning 8230 spsearch error. No backup!

        I believe those accounts are created by SharePoint. I remember seeing this problem somewhere but can't remember exactly. Will try and dig it up. Have you done any other searches or gathered anymore info on this?

        Comment


        • #5
          Re: SBS2011 VSS warning 8230 spsearch error. No backup!

          Most searches point to stuff dated in 2007. I tried removing some registrykeys but that did not work. Still no backup, not to happy at this moment.

          I checked another SBS2011 server from another customer and it to has the same VSS error with user spsearch. Their backup works, but i cannot add an extra HD for backup purposes to it.

          I tried this option from MS, did not work unfortunately.
          http://technet.microsoft.com/en-us/l...35(WS.10).aspx

          Found another URL which is more related to the non backup issue i have. This is prooving to be usefull.

          http://social.technet.microsoft.com/...0-800054e9204b

          [edit]
          The manual backup worked okay, the planned backup worked to. This seemed to have fixed my backup issue. Will try this on the other server where i cannot add backup targets to.
          Last edited by jantje.vlaam; 17th April 2011, 13:43.

          Comment


          • #6
            Re: SBS2011 VSS warning 8230 spsearch error. No backup!

            I also had a SBS2011 migrated from SBS 2003. The backup was fine until one month ago that it stop backup.

            Looking into the Event Viewer and found below :

            -------------------------------------------------------------------------------------

            1) VSS - 8230
            Volume Shadow Copy Service error: Failed resolving account spsearch with status 1376. Check connection to domain controller and VssAccessControl registry key.

            Error-specific details:
            Error: NetLocalGroupGetMember(spsearch), 0x80070560, The specified local group does not exist.

            2) Sharepoint Foundation - 6398
            The Execute method of job definition Microsoft.SharePoint.Search.Administration.SPSearc hJobDefinition (ID 8f3db53c-1526-441c-aec3-bb7145cf65f4) threw and exception. More information is included below.

            The device is not ready.

            3) VSS - 8230
            Volume Shadow Copy Service error: Failed resolving account spsearch with status 1376. Check connection to domain controller and VssAccessControl registry key.

            Operation:
            Gathering Writer Data
            Executing Asynchronous Operation

            Context:
            Execution Context: Requestor
            Current State: GatherWriterMetadata


            Error-specific details:
            Error: NetLocalGroupGetMember(spsearch), 0x80070560, The specified local group does not exist.

            ----------------------------------------------------------------------

            After reviewing that the Sharepoint Error log in the "Sharepoint 2010 Central Administration" portal. I found following errros:

            1. Performance - Databases exist on servers running Sharepoint Foundation
            2. Configuration - Databases require upgrade or not supported
            3. Configuration - Missing server side dependencies
            4. Configuration - Databases running in compatibility range, upgrade recommended.

            ------------------------------------------------------------------------

            As my copy of SBS 2011 was migrated from SBS 2003, the sharepoint also migrated from 2.0 to 3.0 during the upgrade procedure. I suspect that there might have problems in the configuration of the Sharepoint in SBS 2011.

            Therefore I run the "Sharepoint 2010 Products Configuration Wizard" and after that.... Wa la..

            The backup function in SBS 2011 is back to normal now.

            I hope this information can help others to overcome the issue.

            Comment


            • #7
              Re: SBS2011 VSS warning 8230 spsearch error. No backup!

              Sharepoint updating is a two stage process. Have you run the second phase as explained here
              Last edited by teiger; 12th July 2011, 12:32. Reason: Typo
              TIA

              Steven Teiger [SBS-MVP(2003-2009)]
              http://www.wintra.co.il/
              sigpic
              Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

              We donít stop playing because we grow old, we grow old because we stop playing.

              Comment


              • #8
                Re: SBS2011 VSS warning 8230 spsearch error. No backup!

                Teiger Post: 12th July 2011 - Thank you very much

                This article fixes the issue of windows backups not running, but not the VSS Warnings in Event Viewer

                I am currently working on the VSS Warnings will post agin if I find a solution

                Thank You Everybody

                Dan

                Platform: Windows Small Business Server 2011 Fresh Install

                Comment


                • #9
                  Re: SBS2011 VSS warning 8230 spsearch error. No backup!

                  I also have the same problem, I solved it to check the Volume Shadow Copy in Services, if it is Manual start up, you can start it by yourself and backup will run correctly, I tested for backup a few times are all running, after that I changed the Volume Shadow Copy Services to make it start automatically.

                  Comment


                  • #10
                    Re: SBS2011 VSS warning 8230 spsearch error. No backup!

                    I just uninstalled the Sharepoint Foundation 2010 as it is not in use. Problem solved...

                    Comment


                    • #11
                      Re: SBS2011 VSS warning 8230 spsearch error. No backup!

                      Hi,

                      We have had many customers experiencing the same issue. They were running an SBS 2011 in a VM and when our software initiated a backup on the host the SBS 2011 VSS was failing.

                      We managed to find a way how to solve it and just blogged about it. You need to run the PSConfig.exe -cmd upgrade -inplace b2b -force -cmd applicationcontent -install -cmd installfeatures command.

                      More info on our altaro.com/blog/

                      (Tried to post the direct link to the article but wasn't allowed - sorry )

                      Thanks.

                      David Vella

                      Comment


                      • #12
                        Re: SBS2011 VSS warning 8230 spsearch error. No backup!

                        I posted the solution to this back in July along with the link showing that command:
                        http://blogs.technet.com/b/sbs/archi...-2010-sp1.aspx
                        Why are you re-blogging this?
                        TIA

                        Steven Teiger [SBS-MVP(2003-2009)]
                        http://www.wintra.co.il/
                        sigpic
                        Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

                        We donít stop playing because we grow old, we grow old because we stop playing.

                        Comment


                        • #13
                          Re: SBS2011 VSS warning 8230 spsearch error. No backup!

                          I am sorry - I didn't see it and to be honest it took me some time to find it now as well due to the tiny link.

                          Again, sorry about that - please delete my post as it's obviously extra.

                          Comment


                          • #14
                            Re: SBS2011 VSS warning 8230 spsearch error. No backup!

                            Similar problem here. Both the SP VSS Writer and Timer run under spfarm account but neither will start producing Error 1069 "did not start due to logon failure". SP shell reckons it doesn't need upgrading when running (...)NeedsUpgrade command. BTW the PSConfig command suggested in the link kept failing at 10% till I found a different, shorter version of it suggested by Susan Bradley if I remember the name. My RWW, OWA and companyweb are down. SP Configuration Wizard fails. Backup runs just fine. Logs showing

                            EvID:8230
                            Volume Shadow Copy Service error: Failed resolving account spsearch with status 1376. Check connection to domain controller and VssAccessControl registry key.
                            Operation:
                            Gathering Writer Data
                            Executing Asynchronous Operation
                            Context:
                            Execution Context: Requestor
                            Current State: GatherWriterMetadata
                            Error-specific details:
                            Error: NetLocalGroupGetMemebers(spsearch), 0x80070560, The specified local group does not exist.

                            EvID:7000
                            The SharePoint 2010 Timer service failed to start due to the following error:
                            The service did not start due to a logon failure

                            EvID:7038
                            The SPTimerV4 service was unable to log on as DOMAIN\spfarm with the currently configured password due to the following error:
                            Logon failure: unknown user name or bad password.
                            To ensure that the service is configured properly, use the Services snap-in in Microsoft Management Console (MMC).
                            Last edited by yaro137; 12th March 2012, 00:22.

                            Comment

                            Working...
                            X