No announcement yet.

Maybe Windows update corrupted the registry?

  • Filter
  • Time
  • Show
Clear All
new posts

  • Maybe Windows update corrupted the registry?


    I am rather inexperienced in what I'm doing here, so if things aren't clear enough I will do my best to make them clearer. I am a developer at a small company and sometimes the IT department as well.

    Right now I am having major issues with our SBS 2003, which is also running Exchange.

    This morning two windows updates were applied: KB2264107 and KB2419635. Server was then rebooted. Upon startup I get a message saying "At least one driver or service failed, check the event logs."

    Now I cannot login through RDP anymore...

    After logging into the server locally:
    • Exchange isn't running anymore. BAD!
    • I can look at the listing of events in each of the logs, but cannot open events to get the details.
    • I cannot launch IE to look up event ids.
    • I tried to uninstall the previously installed updates. It just hangs.
    • Most things in Server Admin are non-responsive. I can select items but the options do nothing.
    • Active Directory gives the message "Naming info cannot be located because: The workstation driver is not installed. Contact system admin... (me doh!)" and nothing shows up.
    • Services don't show up in advanced tab. Only available in standard.

    I tried booting to safe mode, with no results. The machine starts to load Windows, but then reboots.

    I also tried booting into last known good configuration, which is apparently the current configuration.

    I'm at a loss for what to do. Any suggestions?

    Thanks in advance,
    Last edited by zeilstar; 12th January 2011, 21:53.

  • #2
    Re: Maybe Windows update corrupted the registry?

    Checked ipconfig on this server and it has the correct IP address. However I cannot ping my domain controller box. It says destination unreachable.

    During a reboot I ping -t and see that it replies back for about a minute, then it shows request timed out. Not sure what that all means, but it is probably why services aren't starting because the Admin account can't authenticate with the DC.


    • #3
      Re: Maybe Windows update corrupted the registry?

      Have you considered a restore from backup?
      Tom Jones
      MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
      PhD, MSc, FIAP, MIITT
      IT Trainer / Consultant
      Ossian Ltd

      ** Remember to give credit where credit is due and leave reputation points where appropriate **