Announcement

Collapse
No announcement yet.

DNS Setup Problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • DNS Setup Problems

    Hello,

    I have the following hardware setup:

    An ISP gateway, a Router, a Windows SBS 2008 Server

    The Router is connected to the ISP gateway and has its DHCP Server option disabled.

    The server is connected to the Router.

    I used Windows SBS 2008 console to connect to the internet through the wizard which assigned the server to be as the DHCP Server with the following static IP:

    IPv4: 192.168.1.2

    Gateway: 192.168.1.1

    The server connects to the internet, however loading sites is a bit slow and sometime I get a DNS Probe message and it works again when I reload.

    I open the DNS manager on the server, and I right clicked on the server and properties, forwarders I entered the router IP address.

    In the General tab I have the IP listener set to only the IP of the server. and I chose Secure and non secure access.

    Now the real problem is my desktop that is on the domain, is able to connect to the router and obtain an IP address.

    But no internet. It shows I am connected to the internet but browsing give me DNS error messages on the site page.

    The desktop machine has the IPv4 property of the LAN set to DHCP and the DNS entry is set to 192.168.1.2 which is the server

    Can someone be kind enough to provide me with the correct method to setup the DNS on the SBS 2008 so that the server and the clients can connect and resolve their name queries?





    Thank you in advance.

  • #2
    Post a screenshot or the text output from ipconfig /all from the desktop. Can you ping anything outside your network form this desktop? Try 8.8.8.8 or 8.8.4.4 if you don't have any outside IPs to try.
    Check that DHCP has the correct IPs entered for the DG, DNS (SBS box).

    What IPs have you entered in the DNS Forwarder on the SBS 2008 Server? Who do these Forwarder IPs belong to?
    Last edited by JJKing; 28th November 2016, 15:49.

    Comment


    • #3
      screenshot attached. Notice that the client can ping 8.8.8.8 with some timeouts.

      the IP inside the dns is the IP of the server (192.168.1.2)
      IP in the DNS forwarder on the SBS 2008 is the router IP (192.168.1.1)
      hope this helps
      Attached Files

      Comment


      • #4
        You didn't mention this machine or any others were running on wireless. It may or it may not have a bearing on your issues.

        The DNS Forwarder IPs or screenshot is missing. Not sure what happened to the images you posted as the "ping" one is ok but the "ipconfig" one is really, really tiny and needs to be opened by clicking on it. I did forget to get you to ping a URL from that machine. Sorry about that. The idea is if you can ping an IP then you have connectivity to the outside. If you ping a URL then if it doesn't work you have DNS not resolving. If it does ping then DNS is resolving.

        Try pinging the Server and use the -t switch. I am curious to see how many dropouts you get when it runs for 20 or 30 pings.

        I would suggest you try disabling IPv6 as that has been known to cause different issues especially on Server 2008 unless your ISP has assigned you an IPv6 address.

        I didn't answer your last question because I was waiting to see what you had set in the DNS Forwarders. It is usual to enter the DNS IPs of your ISP. Failing that then you could use the 2 Google DNS IPs that are in my first post. I am not SBS literate so it may be that you use a Wizard to set this up. I am just used to adding them direct. I hope some clever SBS people read this and reveal the SBS way of adding the DNS Forwarders.

        How much of your network is wireless and how much wired?
        Do you have the same Internet issue with the wired machines?
        What operating system do you have running on your workstation/laptops?
        How were they joined to the SBS Server? Manually or did you use the wizard?

        The below is an IPCONFIG /ALL . You have posted an IPCONFIG image. You screenshot has info missing from it. I have blanked my DNS IPs as they are external. Yours should read 192.168.1.2

        Click image for larger version  Name:	ipconfig-all.png Views:	1 Size:	31.8 KB ID:	507981

        Have you had Profile issues/corruption on the machine you posted the ping screenshot from? Just looking at the Command Prompt and saw the .EIMS.000> name and wondered.
        Last edited by JJKing; 29th November 2016, 17:05.

        Comment


        • #5
          Please don't disable IPv6 on SBS as you are likely to have Exchange issues!
          TIA

          Steven Teiger [SBS-MVP(2003-2009)]
          http://www.wintra.co.il/
          sigpic
          Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

          We donít stop playing because we grow old, we grow old because we stop playing.

          Comment


          • #6
            Originally posted by teiger View Post
            Please don't disable IPv6 on SBS as you are likely to have Exchange issues!
            Thank you for pointing that out Steven. Bloody Microsoft, leave IPv6 enabled and it may screw you up. Disable it and it may screw you up. Can't win.

            Comment


            • #7
              Getting off topic, but I have not seen any problems with IPv6 and SBS2011 - with 2008 (Exchange 2007) the recommendation was to disable it, but with 2011/Exchange 2010 it is definitely to leave it on
              Tom Jones
              MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
              PhD, MSc, FIAP, MIITT
              IT Trainer / Consultant
              Ossian Ltd
              Scotland

              ** Remember to give credit where credit is due and leave reputation points where appropriate **

              Comment


              • #8
                Originally posted by Ossian View Post
                Getting off topic, but I have not seen any problems with IPv6 and SBS2011 - with 2008 (Exchange 2007) the recommendation was to disable it, but with 2011/Exchange 2010 it is definitely to leave it on
                My brain hurts.
                1 1 was a racehorse.
                2 2 was 1 2.
                1 1 1 1 race 1 day,
                2 2 1 1 2

                Comment


                • #9
                  Can you do a tracert on the computer which is slow - tracert www.google.co.uk I suspect its a problem with your DNS forwarders... Looking at your original post "properties, forwarders I entered the router IP address." you would need to put either your ISP's DNS here or Googles public DNS and or another

                  Comment

                  Working...
                  X