No announcement yet.

Cannot mount public folder database

  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot mount public folder database

    Using SBS2008 SP1, in Exchange Management Console the Public Folder Database is dismounted and refuses to mount with the error:
    Microsoft Exchange Error
    Failed to mount database 'Public Folder Database'.

    Public Folder Database
    Exchange is unable to mount the database that you specified. Specified database: SERVER1\Second Storage Group\Public Folder Database; Error code: MapiExceptionJetErrorAttachedDatabaseMismatch: Unable to mount database. (hr=0x80004005, ec=-1216)

    What I have done to try and fix this (after every action, I try to mount the db but get the same error):
    • I have restored the public folder database from a backup dated prior to the problem, but it refuses to mount (same error). I restored from a backup even earlier than that (same error)
    • I ran eseutil /mh and I can see that it is in a clean shutdown state.
    • I ran eseutil /r E01
    • I moved the log files to another folder.
    • I ran eseutil /p
    • I used the ESM Toolbox to repair the database, but it just said there were no problems with the database.
    • I have searched google and bing, much of which refers to Exchange 2003, but what I learned from 2007 results is what I have done above.

    Also, I ran isinteg but I got this:
    Isinteg cannot initiate verification process. Please review the log file for more information.
    I do not know where the log files are that it is referring to, and I don't seem to be able to find out where on google or bing.

    My feeling is that there is nothing wrong with the database - but cannot see why it won't mount. Thanks if you can offer any help!
    Best wishes,
    MCP:Server 2003; MCITP:Server 2008; MCTS: SBS2008