Announcement

Collapse
No announcement yet.

ActiveSync on SBS 2003

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ActiveSync on SBS 2003

    Hi,

    I've spent days trying to get activesync to function correctly in our environment and needs somm assistance. I've had a look on the internet for support and cannot find one solution that would work, particularly for an IPHONE device.

    The current environment is as follows:
    Windows Server 2003 for Small Business Server SP2.
    Exchange Server 2003 SP2.
    ISA 2000 SP2.

    The SBS server is a DC and has Exchange 2003 running on it. This is the only DC and Exchange server in the environment. The ISA server acts as a proxy\Firewall.
    Outlook Web Access (OWA) functions ok, so does OMA and RPC over HTTP.
    We have a valid 3rd Party Verisign certificate.
    I've done some tests using https://testexchangeconnectivity.com/ and get an error:
    "The IIS configuration is being checked for client certificate authentication.
    Client certificate authentication wasn't detected.
    Additional Details
    Accept/Require Client Certificates not configured.

    Testing Http Authentication Methods for URL https://webmail.domain.com/Microsoft-Server-Activesync/
    The HTTP authentication test failed.
    Tell me more about this issue and how to resolve it
    Additional Details
    Initial Anonymous HTTP(s) request did not fail but Anonymous is not a supported Authentication Method for this scenario"

    I have modified the URL for privacy reasons. When I click on the help "tell me more...'" is sends me to the following technet library: http://technet.microsoft.com/en-au/l...EXCHG.80).aspx
    Which doesn't really help.

    I've tried disabling form based authentication on teh exchange virtual directory: http://support.microsoft.com/kb/817379, this did not help.
    One thing I noticed on the Default Web Site is up restrictions to loopback and another IP address, Should that matter? or should we grant access to all and filter it through to all virtual directories?

    Outlook Mobile access is anabled and can browse to exchange-oma successfully.

    The ISA LOGS are as follows:
    IP Address anonymous Microsoft-Server-ActiveSync/12.0+(TestExchangeConnectivity.com) 2010-07-06 00:14:45 Servername - webmail.domain.com - - - 190 224 http OPTIONS http://webmail.domain.com:443/Micros...er-Activesync/ - 0
    IP address anonymous Microsoft-Server-ActiveSync/12.0+(TestExchangeConnectivity.com) 2010-07-06 00:14:46 ServerName - webmail.domain.com - - - 190 224 http OPTIONS http://webmail.domain.com:443/Micros...er-Activesync/ - 0

    I'm not sure what this means.
    If I try and browse directly from external to https://webmail.domain.com/Microsoft-Server-Activesync/ is comes up with a logon prompt, after I enter the details it comes up with "The website is unable to display the webpage
    HTTP 501/HTTP 505 ".

    From the Iphone device it comes up with "Unable to verify account information".


    Any help would be great. Thanks.

  • #2
    Re: ActiveSync on SBS 2003

    Why are you trying to use activisync for a iphone?

    Without checking google, I do not even know if its possible to use Async with the iphone, but I can not think of any reason why you would need to?

    What are you trying to achive? The syncing of items to a MS exchange mailbox? This is done via the Exchange connector under settings (when you are setting up your mail account options, one if for MS exchange, it will setup the syncing). If you want to sync files on the iphone, you use Itunes.

    I am sorry if I can not see it (I am going blind) but no where have you said what you actuly wanted to achive, as in all the iphones I have setup, I have never once used Async.

    Here is a guide for connecting the iphone to exchange.
    http://www.talkiphone.com/forums/iph...ge-2003-a.html

    Wofen
    Good to be back....

    Comment


    • #3
      Re: ActiveSync on SBS 2003

      Hi,

      I was actually following this: http://images.apple.com/iphone/busin...e_Business.pdf

      ActiveSync is suppose to work but can't even get an initial connection to the exchange server 'Exchange verification failed'. Have tried different combinations of What I want to achieve is an Iphone connection to our Exchange server. There are two ways, I've tried both activesync and imap of which none work on the Iphone even following those instructions you gave me. For Imap though I think some additional ports will need to be opened on the firewall. On the Iphone I'm using the -Mail-Exchange Server option to setup a mail account.

      Thanks

      Comment


      • #4
        Re: ActiveSync on SBS 2003

        Below are some links you can check out, but its just what I have googled. I have never had a problem with setting up a iphone, so I do not know how much help I can be.

        In saying that, I have never done one with a ISA 2000 server.

        Wofen
        Good to be back....

        Comment


        • #5
          Re: ActiveSync on SBS 2003

          Easiest solution is to get a 3rd party certificate (e.g. www.godaddy.com) for about $30 per year and install that on your SBS box. Iphones trust them and you can bring back HTTPS (otherwise all your data is unencrypted, opening major security holes)
          Tom Jones
          MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
          PhD, MSc, FIAP, MIITT
          IT Trainer / Consultant
          Ossian Ltd
          Scotland

          ** Remember to give credit where credit is due and leave reputation points where appropriate **

          Comment


          • #6
            Re: ActiveSync on SBS 2003

            Wofen: that link you provided specifially asks how to connect an iPhone via ActiveSync, although the question is answered in terms of IMAP. iPhones have supported Exchange ActiveSync since around March '08 and no longer require IMAP to the internet.

            Anyway, the only port you need open to the internet on ISA (or any other firewall for that matter) for ActiveSync is 443. The ActiveSync virtual directory must be configured for Basic Authentication. I'm pretty sure that the directory is not browsable so the 501 error may well be expected behaviour.

            Is the ISA a seperate box or do you have SBS 2003 Premium? If so it is (or was ) possible to upgrade it to ISA 2004 via a service pack, which would be a sensible option IMO.
            BSc, MCSA: Server 2008, MCSE, MCSA: Messaging, MCTS
            sigpic
            Cruachan's Blog

            Comment


            • #7
              Re: ActiveSync on SBS 2003

              Hi,

              Thank you all for your input but I have found the problem. I haven't seen this documented anywhere on Apple of Microsoft but what fixed it for be is allowing WebDAV web extensions in IIS. Hopefully that helps other people having similar problems.

              Cheers

              Comment

              Working...
              X