Announcement

Collapse
No announcement yet.

Internet connection

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Internet connection

    Hi Guys,

    I'm having a problem with my SBS 2008 server's internet connection. Everytime I restart the server, the internet no longer works and I must run the 'Connect to the internet' wizard for it to work again.

    Does anybody know why this may be happening and a possible solution?


    Thanks in advance.
    Last edited by gerdy; 24th May 2010, 11:48.

  • #2
    Re: Internet connection

    Perhaps your dial up modem is faulty?

    On the off chance you connect to the internet in a different way, a wee hint would really help us
    Tom Jones
    MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
    PhD, MSc, FIAP, MIITT
    IT Trainer / Consultant
    Ossian Ltd
    Scotland

    ** Remember to give credit where credit is due and leave reputation points where appropriate **

    Comment


    • #3
      Re: Internet connection

      Originally posted by Ossian View Post
      Perhaps your dial up modem is faulty?

      On the off chance you connect to the internet in a different way, a wee hint would really help us
      Thanks for replying. I've already tried another router but with the same outcome.

      There is nothing special about the internet connection. An ADSL2+ modem with open ports on the firewall for the server, DHCP off on the router, etc. And the wizard is used to connect to the internet.

      Comment


      • #4
        Re: Internet connection

        I suggest you start off by moving DHCP to the SBS -- it is a lot happier that way

        Does everything connect directly to the router (one NiC in the server) or do they connect via the server (2 NiCs, one internal and one external)

        Anything in the event logs?
        Can you post an IPCONFIG/ALL from the server?
        Tom Jones
        MCT, MCSE (2000:Security & 2003), MCSA:Security & Messaging, MCDBA, MCDST, MCITP(EA, EMA, SA, EDA, ES, CS), MCTS, MCP, Sec+
        PhD, MSc, FIAP, MIITT
        IT Trainer / Consultant
        Ossian Ltd
        Scotland

        ** Remember to give credit where credit is due and leave reputation points where appropriate **

        Comment


        • #5
          Re: Internet connection

          After searching the internets, I came across a MS kb article that resolves the problem which is present with SP2.

          http://support.microsoft.com/kb/973243


          I did not however use the hotfix in the KB but rather applied a different fix. This included removing the white space line before the 'DefaultGateway' key in the registry and then restarting.
          HKLM/System/CurrentControlSet/Services/Tcpip/Parameters/Interfaces/{clsid}/

          This seems to be the cause of the internet not working after reboot. I believe this is essentially what the hotfix in the KB above does but decided to do it manually.

          Comment


          • #6
            Re: Internet connection

            Yea I had the same problem. If you had done an ipconfig after restarting, you would have noticed that the default gateway was blank. When the server restarts it reads the registy key and sees the blank space so it leaves it blank. It would even give my clients a blank default gateway. Removing the blank space in the registry key fixed it right up.

            Comment

            Working...
            X