Announcement

Collapse
No announcement yet.

Migration mistake with OAB

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Migration mistake with OAB

    I'm part way through a 2003 to 2008 SBS migration and I made a very clumsy mistake. After moving the public folders from source to destination successfully, I accidentally removed the source OAB from the Exchange Management-Organisation Configuration-Mailbox-Offline Address Book tab. Before moving the OAB. The destination OAB was listed, so I just continued and added the Distribution virtual directory. This was done overnight, so I scheduled a visit the next day onsite to survey the damage.

    The next morning, newly migrated Outlook 2007 users were being regularly prompted for credentials to log into Outlook. Cancelling the prompt would work, but entering the correct details would simply return the dialog box again. They were also receiving error 0x8004010f upon pressing Send/Receive. Outlook 2003 users were only receiving the latter error.

    I right clicked on the OAB and selected update, but received events 9340 and 9360. I then added the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\MSExchangeSA\Parameters\OAL post full if diff fails reg key and ran the update again. After a restart, I was no longer receiving OAB errors on Outlook clients. However, Outlook 2007 users are still prompted for credentials. If I add the Exchange proxy settings, then the errors disappear. But this should not need to be done.

    I have two questions:

    1. should I perform any more operations to "fix" the OAB, despite the errors clearing up?

    2. Are the Outlook 2007 prompts related to this mistake? Seems to be a little coincidental. If not, how can this be fixed separately?

    I've done about a dozen migrations before without incident, so I'm a quite annoyed at this hiccup.

  • #2
    Re: Migration mistake with OAB

    This blog post might help with the OL 2k7 credentials issue.

    http://blogs.technet.com/sbs/archive...rver-2008.aspx

    Comment


    • #3
      Re: Migration mistake with OAB

      No luck with that link, BigStan.

      I've tested connectivity with https://testexchangeconnectivity.com and I get the warning:

      Validating certificate trust:

      Only able to build certificate chain when using the Root Certificate Update functionality from Windows Update. Your server may not be properly configured to send down the required intermediate certificates to complete the chain. Consult the certificate installation instructions or FAQ's from your Certificate Authority for more information.


      The most common solution to this problem is to disable IPv6, but I'm not about to do that on SBS 2008 for only this reason. I know it can be done safely with the correct procedure, but I doubt that is the underlying problem.

      I'm using a Godaddy wildcard certificate and I've installed it with the SBS wizard, plus installed the Intermediate certificate according to Godaddy's IIS7 instructions.

      Comment


      • #4
        Re: Migration mistake with OAB

        Originally posted by craeze View Post

        The most common solution to this problem is to disable IPv6, but I'm not about to do that on SBS 2008 for only this reason. I know it can be done safely with the correct procedure, but I doubt that is the underlying problem.
        See http://blogs.technet.com/sbs/archive...rver-2008.aspx as a possible problem.

        Also don't even consider blocking IPv6. See http://blogs.technet.com/sbs/archive...-sbs-2008.aspx
        Last edited by teiger; 25th February 2010, 10:46. Reason: Typo
        TIA

        Steven Teiger [SBS-MVP(2003-2009)]
        http://www.wintra.co.il/
        sigpic
        Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

        We donít stop playing because we grow old, we grow old because we stop playing.

        Comment


        • #5
          Re: Migration mistake with OAB

          Hi teiger,

          The first link I had already considered, but I have 4 other sites with Godaddy certificates (they aren't wildcards like I originally mentioned for some reason) that haven't been configured with the autodiscover record - and they work just fine. The certificate is remote.domain.com - the server and the client have the same certificate, no errors - the only problem is Outlook 2007.

          The 2nd link actually shows how to disable IPv6 properly - so no need to discourage.

          Comment


          • #6
            Re: Migration mistake with OAB

            Originally posted by craeze View Post
            Hi teiger,

            The first link I had already considered, but I have 4 other sites with Godaddy certificates (they aren't wildcards like I originally mentioned for some reason) that haven't been configured with the autodiscover record - and they work just fine. The certificate is remote.domain.com - the server and the client have the same certificate, no errors - the only problem is Outlook 2007.

            The 2nd link actually shows how to disable IPv6 properly - so no need to discourage.
            1. Can you do a test email autoconfiguration and tell us the results please...

            2. Check autodiscover/EWS/OAB authentication settings on IIS

            Auto = BASIC+Win Integreated
            EWS & OAB = Windows Integrated Only

            3. Make sure you have followed http://support.microsoft.com/kb/940726

            4. Make sure Default OAB on Exchange mgmt console has PF + Web Distribution mechanism enabled.

            5. Go to EMC--->Server Configuration --->Mailbox-->properties of Mailbox Database-->Client settings-->Under Offline Address Book make sure Default OAB which has PF + Web distribution mechanism enabled is selected.

            One more question: do you use proxy settings on your IE? I say this because if you do then autodiscover wont like it. so check : on IE-->Tools-->Internet Options-->Connection and remove any proxy details from LAN Settings and then restart Outlook 2007.


            Regards
            Jedi001
            Technical Director
            www.tecguruz.com
            Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified

            Comment

            Working...
            X