Announcement

Collapse
No announcement yet.

Exchange webmail

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Exchange webmail

    Hi,

    Untill last saturday/sunday my exchange webmail worked fine for all users.
    Today my users received the message 404, I have found some solutions and it seems to work but only for a couple of users.
    All users have the rights set to use webmail but only administrative accounts can login to the webinterface. The regular users receive a message that either name or password is wrong but nothing has changed.
    I have checked all account setting foor IIS and users but cannot find anything wrong esspecially since administrative accounts can use webmail.


    Does any know or did anyone have this problem and found a solution.

    I guess it must have something to do with the latest MS update but how do you explain that for some accounts login is possible.

    TIA.

    Gerhard

  • #2
    Re: Exchange webmail

    Try using <domain>\<user> in the OWA (Webmail) login screen instead of just <user> and see if it makes a difference.
    TIA

    Steven Teiger [SBS-MVP(2003-2009)]
    http://www.wintra.co.il/
    sigpic
    Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

    We donít stop playing because we grow old, we grow old because we stop playing.

    Comment


    • #3
      Re: Exchange webmail

      Originally posted by gerhard59
      I guess it must have something to do with the latest MS update but how do you explain that for some accounts login is possible
      The explanation is that it probably had nothing to do with the latest MS Updates.

      Did you reboot the Server after it was Updated?
      Any reason why you are using OWA and not the superior RPC over HTTPS?
      Is the URL https://www.domain.com/exchange or
      http://www.domain.com/exchange at the logon screen?
      Do all users have the same version of Internet Explorer?
      Any errors in the Event Viewer?
      What is the full 404 error? Can't find File or Directory or Page not found or Server not found etc?
      Is this happening Internally or Externally when accessing OWA?
      1 1 was a racehorse.
      2 2 was 1 2.
      1 1 1 1 race 1 day,
      2 2 1 1 2

      Comment


      • #4
        Re: Exchange webmail

        The server is always rebooted after updates are installed, that is why I think the updates are causing this. On Dec, 21st updates were installed and after that restart the webmail failed however not for all users.
        The reason for webmail is customer request and incidental use of webmail. Most of the mail is handled internally with Outlook.

        The strange thing is that for administrator and my account webmail works both internal and external. I have checked the other accounts and they are all allowed to use webmail.
        Eventlogs only shows a message about not all isapi.dll's being loaded but that is not at the time of using the webmail.
        I have created a new user to test but this new user is also not allowed to login. Message is "user cannot login either name or password is wrong.
        Even tried a copy of a working account but this new user also has no access.
        For the test I use IExplorer on the server and access the localhost.
        As I say the only difference since before and after is the M$ updates, I have removed these and will try after a restart tonight.

        All testing is done with https://localhost/exchange, internal IP address and external IP address

        Originally posted by biggles77 View Post
        The explanation is that it probably had nothing to do with the latest MS Updates.

        Did you reboot the Server after it was Updated?
        Any reason why you are using OWA and not the superior RPC over HTTPS?
        Is the URL https://www.domain.com/exchange or
        http://www.domain.com/exchange at the logon screen?
        Do all users have the same version of Internet Explorer?
        Any errors in the Event Viewer?
        What is the full 404 error? Can't find File or Directory or Page not found or Server not found etc?
        Is this happening Internally or Externally when accessing OWA?

        Comment


        • #5
          Re: Exchange webmail

          The problem is still open. Anyone have more clues where to find a solution.

          I have checked an rechecked al parts involved in the webmail and compared to another installation. There seem to be no differences in the settings.

          With administrator account I can login to outlook web access, I have added user accounts to administrators and domain admins to see if this makes a difference but no success.
          I tried resetting the webmail access attributes with mail accounts but no success.

          Created a new account with admin privilege but this account also has no access to webmail. For some unknown reason only the administrator is allowed access to webmail, all other accounts get message that either name or password is wrong.

          What am I missing in my search for a solution?

          Comment


          • #6
            Re: Exchange webmail

            Check permissions in IIS. If the Admin account can access then it seems that OWA is still working.
            Any errors in the Event Viewer?
            1 1 was a racehorse.
            2 2 was 1 2.
            1 1 1 1 race 1 day,
            2 2 1 1 2

            Comment


            • #7
              Re: Exchange webmail

              I have compared IIS permissions with another server that works and can't find any difference in permissions.
              I added one of the users to the administrators group and also to domain admins but then the user still can't login.
              Copied administrator account but newly created user can't login.
              There are no entries in the eventlogs about these logins or errors concerning IIS.
              Any new account created with mailbox is unable to login to webmail.

              Comment


              • #8
                Re: Exchange webmail

                Re-run the CEICW.
                If your domain is called "mydomain" and the user called "gerhard", try logging in as mydomain\gerhard instead of just gerhard.
                TIA

                Steven Teiger [SBS-MVP(2003-2009)]
                http://www.wintra.co.il/
                sigpic
                Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

                We donít stop playing because we grow old, we grow old because we stop playing.

                Comment


                • #9
                  Re: Exchange webmail

                  Hi Teiger,

                  Thanks for the input, I have tried the different logins already such as
                  domain\user, [email protected] and [email protected]
                  None of the logins work for the users.
                  For administrator I can login with all of the above.
                  I did rerun the CEICW already. Before I posted my question I did a lot of google searching on the subject and found a lot of pssible options for solving.
                  None of the solutions found solved the problem.
                  BTW this forum has the best solutions for many problems compared to a lot of information found.

                  Comment


                  • #10
                    Re: Exchange webmail

                    Do a screen capture of the page when it errors and attach it to your next post. Please save it in MSPaint as a JPG.
                    1 1 was a racehorse.
                    2 2 was 1 2.
                    1 1 1 1 race 1 day,
                    2 2 1 1 2

                    Comment


                    • #11
                      Re: Exchange webmail

                      There is not much to show after a failed login from a user.
                      On opening the url to the webmail I get the regular login page.
                      When a user tries to login the below text is displayed in red, it's in dutch sorry.

                      U kunt niet worden aangemeld bij Outlook Web Access. Controleer of uw gebruikersnaam en het wachtwoord juist zijn en probeer het vervolgens opnieuw.

                      in English
                      You can not log on to Outlook Web Access. Check your username and password are correct and try again.

                      After a faulty login no errors in eventlogs or IIS logfiles.

                      Comment


                      • #12
                        Re: Exchange webmail

                        Since this has been going on for a while, I suggest you contact SBS-MVP Marina Roos. She speaks your language and is one of the partners in smallbizserver.net.
                        Contact me privately if you need her e-mail or other details.
                        TIA

                        Steven Teiger [SBS-MVP(2003-2009)]
                        http://www.wintra.co.il/
                        sigpic
                        Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

                        We donít stop playing because we grow old, we grow old because we stop playing.

                        Comment

                        Working...
                        X