No announcement yet.

WSS 3.0 inaccessible after hotfix

  • Filter
  • Time
  • Show
Clear All
new posts

  • WSS 3.0 inaccessible after hotfix

    I have a client with a SBS 2003, with Sharepoint (WSS 3.0) side by side with WSS 2.0. They are running SQL 2005. Last night I installed hotfix 961750 to address a minor time zone issue. However, upon restart, the WSS site was inaccessible. The application log showed the following errors:

    "The schema version ( of the database WSS_Content on SERVER is not consistent with the expected database schema version ( on SERVER. Connections to this database from this server have been blocked to avoid data loss. Upgrade the web front end or the content database to ensure that these versions match."

    There were also a couple of ASP 2.0.50727.0 errors such as:
    "Failed to execute request because the App-Domain could not be created. Error: 0x80070005 Access is denied."

    Since the hotfix couldn't be rolled back, I installed WSS 3.0 SP2. The Products and Technologies wizard failed, and upon searching the log, it showed the first error "The B2B upgrader timer job failed". I searched and found this article:

    Which suggested copying the web.config file from the folder c:\....\12\CONFIG to c:\....\12\TEMPLATE\LAYOUTS.
    The "psconfig -cmd upgrade -inplace b2b -force -wait" then completed successfully. However, I could still not access the WSS site. I've since run the P&T wizard again, which completes successfully, but I get the same error on the page:

    Runtime error - server Error in '/' Application.

    The application event log shows two ASP 2.0.50727.0 errors:

    "Failed to start monitoring changes to 'C:\Inetpub\wwwroot\wss\VirtualDirectories\37407\A pp_Browsers' because access is denied.
    Application virtual path: '/'"


    "Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 17/12/2009 1:09:58 PM
    Event time (UTC): 17/12/2009 5:09:58 AM
    Event ID: ce31253f671347a39c49666400c3ce1a
    Event sequence: 1
    Event occurrence: 1
    Event detail code: 0

    Application information:
    Application domain: /LM/W3SVC/142260059/Root-1-129055001983172190
    Trust level:
    Application Virtual Path: /
    Application Path: C:\Inetpub\wwwroot\wss\VirtualDirectories\37407\
    Machine name: SERVER

    Process information:
    Process ID: 1308
    Process name: w3wp.exe
    Account name: DOMAIN\wssservice

    Exception information:
    Exception type: HttpException
    Exception message: Failed to start monitoring changes to 'C:\Inetpub\wwwroot\wss\VirtualDirectories\37407\A pp_Browsers' because access is denied.

    Request information:
    Request URL: http://server:20097/
    Request path: /
    User host address:
    Is authenticated: False
    Authentication Type:
    Thread account name: DOMAIN\wssservice

    Thread information:
    Thread ID: 1
    Thread account name: DOMAIN\wssservice
    Is impersonating: False
    Stack trace: at System.Web.DirMonCompletion..ctor(DirectoryMonitor dirMon, String dir, Boolean watchSubtree, UInt32 notifyFilter)
    at System.Web.DirectoryMonitor.StartMonitoring()
    at System.Web.DirectoryMonitor.StartMonitoringFile(St ring file, FileChangeEventHandler callback, String alias)
    at System.Web.FileChangesMonitor.ListenToSubdirectory Changes(String dirRoot, String dirToListenTo)
    at System.Web.FileChangesMonitor.StartMonitoringDirec toryRenamesAndBinDirectory(String dir, FileChangeEventHandler callback)
    at System.Web.HttpRuntime.HostingInit(HostingEnvironm entFlags hostingFlags)"

    Some permission changes will probably help, but I'm not sure exactly what to look for here. Help would be much appreciated.
    Last edited by craeze; 17th December 2009, 06:58.

  • #2
    Re: WSS 3.0 inaccessible after hotfix

    This is a known issue and was on the SBS Blog at in May.

    Steven Teiger [SBS-MVP(2003-2009)]
    Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

    We donít stop playing because we grow old, we grow old because we stop playing.


    • #3
      Re: WSS 3.0 inaccessible after hotfix

      Thanks, teiger, but this doesn't quite appear to be the same issue.

      However, I've run the psconfig command (again) successfully. No change.

      I have since temporarily restored access to the database and the central admin by changing the application pool for both sites to DefaultAppPool. That's it - everything works after that. I would still like to be able to fix it so that the original application pools are used.