Announcement

Collapse
No announcement yet.

SBS 2008 - External HTTPS access issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SBS 2008 - External HTTPS access issue

    Hello Forum members,

    This is my first post to this site and I hope I provide all the necessary details for the issue we are facing with our SBS 2008 server. Please do let me know if you require logs or other details.

    Here are the details:

    - SBS 2008 fresh install X64 - Single Server (less than 100 users)
    - We are using sharepoint and Web Applications (all exchange web services)
    - I have created a certificate using MS CA with SAN (multiple DNS names)..common name of the cert: rpc.mydomain.co.uk and we have created an A record of on the external DNS server.
    - Server is connecting to internet via Vigor 2950 router.
    - I have configured NAT for 80/443/987(sharepoint)/25 to be directed to the server
    - Sharepoint website is binded to port 987 (https) and SBS Web Application website is binded to port 80 with hostname: rpc.mydomain.co.uk + https/443 with Microsoft Exchange (common name: rpc.mydomain.co.uk)
    - Internal Network: All works fine on port 80 & 443 for OWA & other web applications, autodiscover works fine as well...I have set all URL for web services/OAB/ClientAccessserver using kb:940726.

    however from external only port 80 works, for HTTPS://rpc.mydomain.co.uk & https://rpc.mydomain.co.uk/owa gives me Internet Explorer cannot display the webpage error.

    I have checked router settings 10 times and I have done many other similar installations and have never seen this issue ever.

    Please advice.
    Regards
    Jedi001
    Last edited by jedi001; 4th December 2009, 21:26.
    Technical Director
    www.tecguruz.com
    Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified

  • #2
    Re: SBS 2008 - External HTTPS access issue

    let's start here:
    from outside the router, can you telnet to port 443 on the ip address of your gateway ?
    Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

    Comment


    • #3
      Re: SBS 2008 - External HTTPS access issue

      Originally posted by tehcamel View Post
      let's start here:
      from outside the router, can you telnet to port 443 on the ip address of your gateway ?
      Thanks for your reply...

      I tried that and the result is

      telnet External_Ip_Address 443...it connects however if I type anything it gets back to the C:\ prompt. For port 80 I can connect and even if I type anything on the telnet session, it does not disconnect me from the session right away...

      Cheers
      Jedi001
      Last edited by jedi001; 4th December 2009, 14:14.
      Technical Director
      www.tecguruz.com
      Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified

      Comment


      • #4
        Re: SBS 2008 - External HTTPS access issue

        ok so - your router is correctly forwarding port 443, to somerthing, that's hosting a service on port 443 inside the network.

        what happens if you try "telnet internal_ip 443" ?
        do you get the same instant disconnect when you try and type ?
        Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

        Comment


        • #5
          Re: SBS 2008 - External HTTPS access issue

          When I tried : telnet Internal_IP_Address 443 on the server, it got me connected and it did not disconnected me instantly.

          Regards
          Jedi001
          Technical Director
          www.tecguruz.com
          Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified

          Comment


          • #6
            Re: SBS 2008 - External HTTPS access issue

            I wonder if maybe you have some sort of issue where you can only connect to HTTPS from a specific range of addresses ? I'm having trouble finding exactly where this optiin is for IIS7 (I know hwere it is for iis6..)

            from technet:
            http://technet.microsoft.com/en-us/l...90(WS.10).aspx

            However - I still can't find same in my environment
            Last edited by tehcamel; 7th December 2009, 00:07.
            Please do show your appreciation to those who assist you by leaving Rep Point https://www.petri.com/forums/core/im.../icon_beer.gif

            Comment


            • #7
              Re: SBS 2008 - External HTTPS access issue

              UTFW - you may be correct in all you are doing but it is easier to Use The F*&^ing Wizard (Connect to Internet) to do it correctly and securely - without compromising your server.
              TIA

              Steven Teiger [SBS-MVP(2003-2009)]
              http://www.wintra.co.il/
              sigpic
              Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

              We donít stop playing because we grow old, we grow old because we stop playing.

              Comment


              • #8
                Re: SBS 2008 - External HTTPS access issue

                Originally posted by teiger View Post
                UTFW - you may be correct in all you are doing but it is easier to Use The F*&^ing Wizard (Connect to Internet) to do it correctly and securely - without compromising your server.
                I have run the Fix My Network wizard...it says there are no issues.

                Techcamel: I will look at the option as well..but not sure whether this could be the issue as I am sure that I have not change any such setting on IIS. As its a fresh installation, it is making it more complicated for me to diagnose.


                Thank you to everyone. Please do suggest more possible causes to this issue as I am not able to deploy things like RPCoverHttps + ActiveSync with SSL. Customers most of the employee work remotely and for this reason i need to find a solution quickly.

                Regards
                Jedi001
                Technical Director
                www.tecguruz.com
                Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified

                Comment


                • #9
                  Re: SBS 2008 - External HTTPS access issue

                  Originally posted by jedi001 View Post
                  I have run the Fix My Network wizard...it says there are no issues.
                  I am asking you to run the Connect to the Internet Wizard (Fix my Network Wizard is more for LAN issues than WAN ones)
                  TIA

                  Steven Teiger [SBS-MVP(2003-2009)]
                  http://www.wintra.co.il/
                  sigpic
                  Iím honoured to have been selected for the SMB 150 list for 2013. This is the third time in succession (no logo available for 2011) that I have been honoured with this award.

                  We donít stop playing because we grow old, we grow old because we stop playing.

                  Comment


                  • #10
                    Re: SBS 2008 - External HTTPS access issue

                    Originally posted by teiger View Post
                    I am asking you to run the Connect to the Internet Wizard (Fix my Network Wizard is more for LAN issues than WAN ones)
                    Apologies..forgot to mention that i did run 'Connect to the Internet' wizard and I was able to connect to the internet just fine.

                    Please do let me know if you need any other information...

                    Cheers
                    Jedi001
                    Technical Director
                    www.tecguruz.com
                    Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified

                    Comment


                    • #11
                      Re: SBS 2008 - External HTTPS access issue

                      No I am a bit lost. Where is Google maps when you need it.

                      Is everything working except these 2 items? HTTPS://rpc.mydomain.co.uk & https://rpc.mydomain.co.uk/owa

                      Have you got the correct Ports being Forwarded to the correct IP in the Router?
                      Are the Permissions in IIS correctly set?
                      Have you tried a different Router?
                      Have you updated the Firmware on your present Router?
                      Have you Googled for problems with this Router and Server 2008 or IE8?
                      Have you tried using a different Web Browser?
                      1 1 was a racehorse.
                      2 2 was 1 2.
                      1 1 1 1 race 1 day,
                      2 2 1 1 2

                      Comment


                      • #12
                        Re: SBS 2008 - External HTTPS access issue

                        Originally posted by biggles77 View Post
                        No I am a bit lost. Where is Google maps when you need it.

                        Is everything working except these 2 items? HTTPS://rpc.mydomain.co.uk & https://rpc.mydomain.co.uk/owa

                        Have you got the correct Ports being Forwarded to the correct IP in the Router?
                        Are the Permissions in IIS correctly set?
                        Have you tried a different Router?
                        Have you updated the Firmware on your present Router?
                        Have you Googled for problems with this Router and Server 2008 or IE8?
                        Have you tried using a different Web Browser?
                        Got the solution to the problem....All was fine on the SBS 2008 server, the problem was found at the router - Vigor2950. The router had SSL VPN port was set to 443 which we change to something else. Now all works fine for us from external network as well. We never tried to configure the SSL VPN on the router, when we called Vigor technical team, they said its a known thing to them....

                        Thanks for all input from all the members.

                        Regards
                        Jedi001
                        Last edited by jedi001; 10th December 2009, 18:31.
                        Technical Director
                        www.tecguruz.com
                        Ex-Microsoft (Exchange Client & Server Infrastructure Team), MCSA, MCSE, MCITP, MCTS & ITIL Foundation certified

                        Comment


                        • #13
                          Re: SBS 2008 - External HTTPS access issue

                          Thanks for posting your result. Saved us a few hours of messing around too. Odd though other companies have the same hardware setup without any issues. We had to change the default HTTPS management port to something other than 443 even though the remote management was disabled.
                          Please remember to leave positive reputation points (The Ying Yang Icon) if someone helps you.

                          Comment


                          • #14
                            Re: SBS 2008 - External HTTPS access issue

                            Thanks for posting solution. Our problem has been resolved now

                            Comment

                            Working...
                            X